summaryrefslogtreecommitdiff
path: root/support/gnuconfig/README.buildroot
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-08-31 23:35:06 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-17 08:22:12 +0200
commit102a93bdca09742c99e110f144bf0c9267bbdd14 (patch)
treee9f3cc83518b09e75177dc1d9994f24f21ca17b5 /support/gnuconfig/README.buildroot
parent56da3859c770b83631ebae810dfb3024c1a9cbd2 (diff)
support: move package/gnuconfig to support/gnuconfig
The CONFIG_UPDATE macro is no longer defined in package/gnuconfig/gnuconfig.mk, but instead in package/Makefile.autotools.in. It it also changed a little bit to take the directory of the package sources as argument, and the AUTOTARGETS infrastructure is updated to use this macro. [Peter: drop echo in CONFIG_UPDATE] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'support/gnuconfig/README.buildroot')
-rw-r--r--support/gnuconfig/README.buildroot25
1 files changed, 25 insertions, 0 deletions
diff --git a/support/gnuconfig/README.buildroot b/support/gnuconfig/README.buildroot
new file mode 100644
index 000000000..d655d6211
--- /dev/null
+++ b/support/gnuconfig/README.buildroot
@@ -0,0 +1,25 @@
+--- HOWTO ---
+If your package uses config.guess and/or config.sub, then it probably
+relies on the autotools as its build system. In this case, you should
+use the AUTOTARGETS infrastructure, which will take care of updating
+the config.guess and/or config.sub files appropriately. See the
+Buildroot documentation for details about the AUTOTARGETS
+infrastructure.
+
+If for some reason your package does not use the AUTOTARGETS
+infrastructure, you can request the config.guess and/or config.sub
+files of your package to be updated by using:
+
+ $(call CONFIG_UPDATE,directory-of-your-package-sources)
+
+--- UPDATE ---
+GNU config is now managed in git, so to update:
+
+# git clone git://git.savannah.gnu.org/config.git
+# cp config/config.* .
+# for p in $(ls patches/*.patch); do patch -p0 < $p; done
+# rm -rf config
+
+A few local customizations are used to support uClibc so you may
+have to make sure they're still needed. The patches are broken
+out in the patches/ dir to keep things simple.