summaryrefslogtreecommitdiff
path: root/support/kconfig/patches/06-br-build-system-integration.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-08-31 23:35:05 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-17 08:17:06 +0200
commit56da3859c770b83631ebae810dfb3024c1a9cbd2 (patch)
tree0f253485b64572a2ec87b6d91cd07f09d2fab652 /support/kconfig/patches/06-br-build-system-integration.patch
parent59a326b934737483531c49c99acda7874c72e335 (diff)
support: move kconfig stuff from package/config to support/kconfig
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'support/kconfig/patches/06-br-build-system-integration.patch')
-rw-r--r--support/kconfig/patches/06-br-build-system-integration.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/support/kconfig/patches/06-br-build-system-integration.patch b/support/kconfig/patches/06-br-build-system-integration.patch
new file mode 100644
index 000000000..8a27e251e
--- /dev/null
+++ b/support/kconfig/patches/06-br-build-system-integration.patch
@@ -0,0 +1,40 @@
+---
+ Makefile | 14 +++++++++++++-
+ 1 file changed, 13 insertions(+), 1 deletion(-)
+
+Index: config/Makefile
+===================================================================
+--- config.orig/Makefile
++++ config/Makefile
+@@ -174,18 +174,30 @@
+ ifeq ($(MAKECMDGOALS),nconfig)
+ hostprogs-y += nconf
+ endif
++ifeq ($(findstring nconf,$(MAKECMDGOALS)),nconf)
++ hostprogs-y += nconf
++endif
+
+ ifeq ($(MAKECMDGOALS),menuconfig)
+ hostprogs-y += mconf
+ endif
++ifeq ($(findstring mconf,$(MAKECMDGOALS)),mconf)
++ hostprogs-y += mconf
++endif
+
+ ifeq ($(MAKECMDGOALS),xconfig)
+ qconf-target := 1
+ endif
++ifeq ($(findstring qconf,$(MAKECMDGOALS)),qconf)
++ qconf-target := 1
++endif
++
+ ifeq ($(MAKECMDGOALS),gconfig)
+ gconf-target := 1
+ endif
+-
++ifeq ($(findstring gconf,$(MAKECMDGOALS)),gconf)
++ gconf-target := 1
++endif
+
+ ifeq ($(qconf-target),1)
+ qconf-cxxobjs := qconf.o