summaryrefslogtreecommitdiff
path: root/target/cramfs
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /target/cramfs
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'target/cramfs')
-rw-r--r--target/cramfs/Makefile.in3
-rw-r--r--target/cramfs/cramfs.mk8
2 files changed, 8 insertions, 3 deletions
diff --git a/target/cramfs/Makefile.in b/target/cramfs/Makefile.in
deleted file mode 100644
index 45d9b67ce..000000000
--- a/target/cramfs/Makefile.in
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_TARGET_ROOTFS_CRAMFS)),y)
-TARGETS+=cramfsroot
-endif
diff --git a/target/cramfs/cramfs.mk b/target/cramfs/cramfs.mk
index a00af6c17..e4766cfad 100644
--- a/target/cramfs/cramfs.mk
+++ b/target/cramfs/cramfs.mk
@@ -49,3 +49,11 @@ cramfsroot-clean:
cramfsroot-dirclean:
rm -rf $(CRAMFS_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_TARGET_ROOTFS_CRAMFS)),y)
+TARGETS+=cramfsroot
+endif