summaryrefslogtreecommitdiff
path: root/target/device/Atmel/at91bootstrap/at91bootstrap.mk
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-26 23:52:31 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-26 23:52:31 +0000
commit0dbf9dd7ab8e08e9081a1141f0122f0e2cdc6202 (patch)
tree098bb98a9d08b6ec633c00178556bdd9955ce8ae /target/device/Atmel/at91bootstrap/at91bootstrap.mk
parent78fa0d4eb4f8ce861664093cb62c1a11b22d90f6 (diff)
Create a common BR2_COPYTO to prepare to replace
all the different COPYTOs spread out all over Buildroot. Generate COPY_FILE subroutine which can be used to copy a file. $(COPY_FILE , file, directory, filename) This will copy to binary dir and to the selected copy dir if set in new config (intended to replace all old COPYTO configs) This is overridden by BUILDROOT_COPYTO, if set into the environment.
Diffstat (limited to 'target/device/Atmel/at91bootstrap/at91bootstrap.mk')
-rw-r--r--target/device/Atmel/at91bootstrap/at91bootstrap.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/target/device/Atmel/at91bootstrap/at91bootstrap.mk b/target/device/Atmel/at91bootstrap/at91bootstrap.mk
index 059d6a134..2b41e8212 100644
--- a/target/device/Atmel/at91bootstrap/at91bootstrap.mk
+++ b/target/device/Atmel/at91bootstrap/at91bootstrap.mk
@@ -71,13 +71,17 @@ $(AT91BOOTSTRAP_DIR)/.installed:: $(AT91BOOTSTRAP_TARGET)
mkdir -p $(BINARIES_DIR)
ifeq ($(AT91BOOTSTRAP_VERSION),2.3)
cp $(AT91BOOTSTRAP_TARGET) $(BINARIES_DIR)/$(AT91BOOTSTRAP_BINARY)
- cp $(AT91BOOTSTRAP_TARGET) $(BR2_TARGET_ATMEL_COPYTO)/$(AT91BOOTSTRAP_BINARY)
+ $(call COPY_FILE, $(AT91BOOTSTRAP_TARGET), $(BR2_TARGET_ATMEL_COPYTO), $(AT91BOOTSTRAP_BINARY))
else
make MEMORY=$(AT91BOOTSTRAP_MEMORY) \
CROSS_COMPILE=$(TARGET_CROSS) \
-C $(AT91BOOTSTRAP_DIR) boot
- make DESTDIR=$(BINARIES_DIR) -C $(AT91BOOTSTRAP_DIR) install
- make DESTDIR=$(BR2_TARGET_ATMEL_COPYTO) -C $(AT91BOOTSTRAP_DIR) install
+ make DESTDIR=$(BINARIES_DIR) -C $(AT91BOOTSTRAP_DIR) install || ±
+ echo "Could not copy bootstrap to BINARIES_DIR"
+ifneq ($(BR2_TARGET_ATMEL_COPYTO),)
+ make DESTDIR=$(BR2_TARGET_ATMEL_COPYTO) -C $(AT91BOOTSTRAP_DIR) install || \
+ echo "Could not copy bootstrap to BR2_ATMEL_COPYTO"
+endif
endif
touch $@