summaryrefslogtreecommitdiff
path: root/target/device/Atmel/at91sam9261ek/Makefile.in
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-03 16:10:50 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-03 16:10:50 +0000
commitcc30201f4700ed1eb76e074bbbcf0f78ea469f07 (patch)
treec4c5ce759a559886fb64669e4a9bcda4b47918ac /target/device/Atmel/at91sam9261ek/Makefile.in
parentc7066b18079daef160592168e51479e82ae4f586 (diff)
Update target/device/Atmel/*/Makefile.in
------------------------------------------ Replace $(BOARDNAME)_PATH with BOARD_PATH Set U-Boot targets for 1.2.0-atmel as well as 2009.01-rc1 Remove hardwiring of BusyBox configuration files. Remove older BusyBox configuration files Remove "at91sam9260dfc-linux-2.6.28-rc6.config" from at91sam9g20dfc directory Update "at91rm9200df_defconfig" Add "at91rm9200df-linux-2.6.28.config" Update "at91sam9260dfc_defconfig"
Diffstat (limited to 'target/device/Atmel/at91sam9261ek/Makefile.in')
-rw-r--r--target/device/Atmel/at91sam9261ek/Makefile.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/target/device/Atmel/at91sam9261ek/Makefile.in b/target/device/Atmel/at91sam9261ek/Makefile.in
index e9074485f..23b5c6d8a 100644
--- a/target/device/Atmel/at91sam9261ek/Makefile.in
+++ b/target/device/Atmel/at91sam9261ek/Makefile.in
@@ -1,12 +1,22 @@
ifeq ($(strip $(BOARD_NAME)),at91sam9261ek)
-BR2_PACKAGE_BUSYBOX_CONFIG:=$(BOARD_PATH)/busybox-1.6.0.config
+LINUX_BOARD_NAME:=at91sam9261ek
+ifeq ($(U_BOOT_VERSION),1.2.0-atmel)
+UBOOT_BOARD_NAME:=at91sam9261ek
+else
ifneq ($(BR2_TARGET_UBOOT_BOOTSOURCE_DATAFLASHCARD),)
UBOOT_BOARD_NAME:=at91sam9261ek_dataflash_cs0
+# use CS0 since we have to route CS0 to the SDcard
+# to allow boot from a card.
+# Note possible conflict with CS3 which needs to be
+# disabled both in U-Boot and in Linux
endif
+
ifneq ($(BR2_TARGET_UBOOT_BOOTSOURCE_DATAFLASH),)
UBOOT_BOARD_NAME:=at91sam9261ek_dataflash_cs0
endif
+
ifneq ($(BR2_TARGET_UBOOT_BOOTSOURCE_NANDFLASH),)
UBOOT_BOARD_NAME:=at91sam9261ek_nandflash
endif
endif
+endif