summaryrefslogtreecommitdiff
path: root/target
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-03-02 22:42:20 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-09 11:04:32 +0200
commita573150c199028c1d03713ca8c801e8187851544 (patch)
tree0a3461bc4e8235b8dae0d746a5fab2fb6b8b852b /target
parent8e599f7fc6404f290db1e9bebd7823aa46d2b34b (diff)
target/iso9660: cleanup
Remove the mkisofs host tools building process, which is now in package/cdrkit. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'target')
-rw-r--r--target/iso9660/Config.in1
-rw-r--r--target/iso9660/iso9660.mk52
2 files changed, 2 insertions, 51 deletions
diff --git a/target/iso9660/Config.in b/target/iso9660/Config.in
index 0b820630a..40c93b3f8 100644
--- a/target/iso9660/Config.in
+++ b/target/iso9660/Config.in
@@ -4,7 +4,6 @@ config BR2_TARGET_ROOTFS_ISO9660
depends on !BR2_KERNEL_none
select BR2_TARGET_ROOTFS_EXT2
select BR2_TARGET_GRUB
- select BR2_HOST_FAKEROOT
help
Build a bootable iso9660 image
diff --git a/target/iso9660/iso9660.mk b/target/iso9660/iso9660.mk
index 9571e4769..a198c17c1 100644
--- a/target/iso9660/iso9660.mk
+++ b/target/iso9660/iso9660.mk
@@ -1,46 +1,5 @@
#############################################################
#
-# mkisofs to build to target iso9660 filesystems
-#
-#############################################################
-MKISOFS_SOURCE:=cdrtools-2.01.tar.bz2
-MKISOFS_CAT:=$(BZCAT)
-MKISOFS_SITE:=ftp://ftp.berlios.de/pub/cdrecord/
-MKISOFS_DIR:=$(BUILD_DIR)/cdrtools-2.01
-MKISOFS_TARGET=$(MKISOFS_DIR)/mkisofs/OBJ/$(HOST_ARCH)-linux-cc/mkisofs
-
-hest:
- @echo ARCH=$(BR2_ARCH) HOST_ARCH=$(HOST_ARCH)
-$(DL_DIR)/$(MKISOFS_SOURCE):
- $(call DOWNLOAD,$(MKISOFS_SITE),$(MKISOFS_SOURCE))
-
-mkisofs-source: $(DL_DIR)/$(MKISOFS_SOURCE)
-
-$(MKISOFS_DIR)/.unpacked: $(DL_DIR)/$(MKISOFS_SOURCE)
- $(MKISOFS_CAT) $(DL_DIR)/$(MKISOFS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- toolchain/patch-kernel.sh $(MKISOFS_DIR) target/iso9660/ \*.patch
- touch $@
-
-$(MKISOFS_DIR)/.configured: $(MKISOFS_DIR)/.unpacked
- (cd $(MKISOFS_DIR); rm -rf config.cache; \
- );
- touch $@
-
-$(MKISOFS_TARGET): $(MKISOFS_DIR)/.configured
- $(MAKE) -C $(MKISOFS_DIR)
- touch -c $(MKISOFS_DIR)/mkisofs
-
-mkisofs: $(MKISOFS_TARGET)
-
-mkisofs-clean:
- -$(MAKE) -C $(MKISOFS_DIR) clean
-
-mkisofs-dirclean:
- rm -rf $(MKISOFS_DIR)
-
-
-#############################################################
-#
# Build the iso96600 root filesystem image
#
#############################################################
@@ -54,7 +13,7 @@ ifeq ($(BR2_TARGET_ROOTFS_ISO9660_SQUASH),y)
ISO9660_OPTS+=-U
endif
-$(ISO9660_TARGET): host-fakeroot $(LINUX_KERNEL) $(EXT2_TARGET) grub mkisofs
+$(ISO9660_TARGET): host-fakeroot host-cdrkit $(LINUX_KERNEL) $(EXT2_TARGET) grub
mkdir -p $(ISO9660_TARGET_DIR)
mkdir -p $(ISO9660_TARGET_DIR)/boot/grub
cp $(GRUB_DIR)/stage2/stage2_eltorito $(ISO9660_TARGET_DIR)/boot/grub/
@@ -67,7 +26,7 @@ $(ISO9660_TARGET): host-fakeroot $(LINUX_KERNEL) $(EXT2_TARGET) grub mkisofs
cat $(BUILD_DIR)/.fakeroot* > $(BUILD_DIR)/_fakeroot.$(notdir $(ISO9660_TARGET))
echo "chown -R 0:0 $(ISO9660_TARGET_DIR)" >> $(BUILD_DIR)/_fakeroot.$(notdir $(ISO9660_TARGET))
# Use fakeroot so mkisofs believes the previous fakery
- echo "$(MKISOFS_TARGET) -R -b boot/grub/stage2_eltorito -no-emul-boot " \
+ echo "$(HOST_DIR)/usr/bin/genisoimage -R -b boot/grub/stage2_eltorito -no-emul-boot " \
"-boot-load-size 4 -boot-info-table -o $(ISO9660_TARGET) $(ISO9660_TARGET_DIR)" \
>> $(BUILD_DIR)/_fakeroot.$(notdir $(ISO9660_TARGET))
chmod a+x $(BUILD_DIR)/_fakeroot.$(notdir $(ISO9660_TARGET))
@@ -78,13 +37,6 @@ iso9660root: $(ISO9660_TARGET)
echo $(ISO9660_TARGET)
@ls -l $(ISO9660_TARGET)
-iso9660root-source: mkisofs-source
-
-iso9660root-clean: mkisofs-clean
-
-iso9660root-dirclean: mkisofs-dirclean
- rm -rf $(ISO9660_DIR)
-
#############################################################
#
# Toplevel Makefile options