summaryrefslogtreecommitdiff
path: root/target
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-04-02 15:00:59 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-04-02 15:00:59 +0200
commitdeb5f91336e13eb93533502111c5cdc807d81bf4 (patch)
tree211503a31b9c5a395921fef133d7da6a019088df /target
parentd3f777e0031c2af8d56a605d0172e66e980ff6c1 (diff)
u-boot: add 2010.03, adapt target mkimage step to work with 2010.03
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'target')
-rw-r--r--target/u-boot/Config.in7
-rw-r--r--target/u-boot/Makefile.in2
2 files changed, 7 insertions, 2 deletions
diff --git a/target/u-boot/Config.in b/target/u-boot/Config.in
index 2689f6975..f84d181e6 100644
--- a/target/u-boot/Config.in
+++ b/target/u-boot/Config.in
@@ -13,12 +13,16 @@ config BR2_TARGET_UBOOT_BOARDNAME
choice
prompt "U-Boot Version"
- default BR2_TARGET_UBOOT_2009_11
+ default BR2_TARGET_UBOOT_2010_03
help
Select the specific U-Boot version you want to use
+config BR2_TARGET_UBOOT_2010_03
+ bool "u-boot-2010.03"
+
config BR2_TARGET_UBOOT_2009_11
bool "u-boot-2009.11"
+ depends on BR2_DEPRECATED || BR2_RECENT
config BR2_TARGET_UBOOT_2009_08
bool "u-boot-2009.08"
@@ -48,6 +52,7 @@ endchoice
config BR2_UBOOT_VERSION
string
+ default "2010.03" if BR2_TARGET_UBOOT_2010_03
default "2009.11" if BR2_TARGET_UBOOT_2009_11
default "2009.08" if BR2_TARGET_UBOOT_2009_08
default "2009.06" if BR2_TARGET_UBOOT_2009_06
diff --git a/target/u-boot/Makefile.in b/target/u-boot/Makefile.in
index 5efbd54d2..d1bb5e531 100644
--- a/target/u-boot/Makefile.in
+++ b/target/u-boot/Makefile.in
@@ -177,7 +177,7 @@ $(TARGET_DIR)/usr/bin/mkimage: $(U_BOOT_DIR)/$(U_BOOT_BIN)
-DUSE_HOSTCC -o $@ \
$(U_BOOT_DIR)/common/image.c \
$(wildcard $(addprefix $(U_BOOT_DIR)/tools/,default_image.c \
- fit_image.c kwbimage.c mkimage.c)) \
+ fit_image.c imximage.c kwbimage.c mkimage.c)) \
$(addprefix $(U_BOOT_DIR)/lib_generic/,crc32.c md5.c sha1.c) \
$(U_BOOT_DIR)/tools/os_support.c \
$(U_BOOT_DIR)/libfdt/fdt*.c