summaryrefslogtreecommitdiff
path: root/target
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-17 13:28:31 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-17 13:28:31 +0000
commit1bb1d9f3967866be96af0c254bd53cbc35785599 (patch)
treeb9c8131834736efe6241b6ac82c14d23ebc73df5 /target
parenta1e6a84bb32d2c691103ee7548506c6bb68cb101 (diff)
Add 'linux26-modules' target to allow external drivers to be built with the kernel. Also, remove 'boot' directory before creating INITRAMFS.
Diffstat (limited to 'target')
-rw-r--r--target/linux/Makefile.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/Makefile.in b/target/linux/Makefile.in
index bee81a7ff..bbb3726d6 100644
--- a/target/linux/Makefile.in
+++ b/target/linux/Makefile.in
@@ -136,7 +136,7 @@ $(TARGET_DIR)/boot/$(LINUX26_FORMAT): $(LINUX26_KERNEL)
cp -dpf $(LINUX26_DIR)/$(LINUX26_BINLOC) $(LINUX26_DIR)/System.map $(TARGET_DIR)/boot/
touch -c $@
-$(TARGET_DIR)/lib/modules/$(LINUX26_VERSION)/modules.dep: $(LINUX26_DIR)/.depend_done
+linux26-modules $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION)/modules.dep: $(LINUX26_DIR)/.depend_done
rm -rf $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION)
rm -f $(TARGET_DIR)/sbin/cardmgr
$(MAKE) $(LINUX26_MAKE_FLAGS) -C $(LINUX26_DIR) modules
@@ -144,6 +144,7 @@ $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION)/modules.dep: $(LINUX26_DIR)/.depend
DEPMOD=$(STAGING_DIR)/bin/$(GNU_TARGET_NAME)-depmod26 \
INSTALL_MOD_PATH=$(TARGET_DIR) modules_install
rm -f $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION)/build
+ rm -f $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION)/source
touch -c $@
linux26-menuconfig: $(LINUX26_DIR)/.patched host-sed