summaryrefslogtreecommitdiff
path: root/target
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-12-08 13:42:04 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-12-08 13:42:04 +0000
commit7cb7952b40a2c40b3c2b451f1d6c028cd439be02 (patch)
tree0bd8ede71906602be2d1c733670389809e15479b /target
parenta7d06d10e45d85dc237d0c4c01eb7e08d018530d (diff)
target/initramfs: actually build initramfs target
Currently, BR2_TARGET_ROOTFS_INITRAMFS doesn't actually do anything, as it doesn't alter $(TARGETS) This change hooks up the TARGETS variable to INITRAMFS_TARGET (which is only set if BR2_TARGET_ROOTFS_INITRAMFS=y), so that the initramfs list is built. Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
Diffstat (limited to 'target')
-rw-r--r--target/initramfs/initramfs.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/initramfs/initramfs.mk b/target/initramfs/initramfs.mk
index 830d30995..6ace2f114 100644
--- a/target/initramfs/initramfs.mk
+++ b/target/initramfs/initramfs.mk
@@ -12,6 +12,8 @@ else
INITRAMFS_TARGET:= #nothing
endif
+TARGETS+=$(INITRAMFS_TARGET)
+
$(INITRAMFS_TARGET) initramfs: host-fakeroot makedevs
rm -f $(TARGET_DIR)/init
ln -s sbin/init $(TARGET_DIR)/init