summaryrefslogtreecommitdiff
path: root/target
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-01-15 17:34:58 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-01-15 17:34:58 +0000
commit8564ba689d507b50ca09ebebe121304bc827cffc (patch)
tree59db8c0b76281663bb81643c3b3f416e933f668b /target
parent56f4eae10df5665225154161dd51a5d6b95470b0 (diff)
- andersee, why was this duplicated and hardcoded here?
Diffstat (limited to 'target')
-rw-r--r--target/device/x86/i386/linux26.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/target/device/x86/i386/linux26.mk b/target/device/x86/i386/linux26.mk
index f6a33fadb..202220036 100644
--- a/target/device/x86/i386/linux26.mk
+++ b/target/device/x86/i386/linux26.mk
@@ -6,12 +6,15 @@
ifneq ($(filter $(TARGETS),linux26),)
+ifeq ($(LINUX_HEADERS_VERSION),)
# Version of Linux to download and then apply patches to
DOWNLOAD_LINUX26_VERSION=2.6.19.1
# Version of Linux after applying any patches
LINUX26_VERSION=2.6.19.1
-
-
+else
+DOWNLOAD_LINUX26_VERSION=$(LINUX_HEADERS_VERSION)
+LINUX26_VERSION=$(LINUX_HEADERS_VERSION)
+endif
LINUX26_SOURCE=linux-$(DOWNLOAD_LINUX26_VERSION).tar.bz2
LINUX26_BZCAT:=$(BZCAT)