summaryrefslogtreecommitdiff
path: root/toolchain/dependencies
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-08-22 09:22:07 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-08-22 09:22:07 +0000
commitaa81a0650884a0563e6dcb41dc15a5635a28481d (patch)
treead8e2788b9b644366128ded4f25bbe9e7e96b582 /toolchain/dependencies
parent26b4c3782b0d6b75e1dc4985a5714cf68566b0a8 (diff)
- improve the way host prerequisites for "dependencies" are established
Diffstat (limited to 'toolchain/dependencies')
-rw-r--r--toolchain/dependencies/dependencies.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/toolchain/dependencies/dependencies.mk b/toolchain/dependencies/dependencies.mk
index 4af03b8f8..d50042462 100644
--- a/toolchain/dependencies/dependencies.mk
+++ b/toolchain/dependencies/dependencies.mk
@@ -5,11 +5,15 @@
#
######################################################################
+DEPENDENCIES_HOST_PREREQ:=
ifeq ($(BR2_STRIP_sstrip),y)
-# XXX: this is a little bit ugly, yep.
-MAYBE_SSTRIP_HOST:=sstrip_host
+DEPENDENCIES_HOST_PREREQ+=sstrip_host
endif
-dependencies: host-sed host-lzma $(MAYBE_SSTRIP_HOST)
+ifneq ($(findstring y,$(BR2_KERNEL_HEADERS_LZMA)),)
+DEPENDENCIES_HOST_PREREQ+=host-lzma
+endif
+
+dependencies: host-sed $(DEPENDENCIES_HOST_PREREQ)
@HOSTCC="$(firstword $(HOSTCC))" MAKE="$(MAKE)" \
HOST_SED_DIR="$(HOST_SED_DIR)" \
$(TOPDIR)/toolchain/dependencies/dependencies.sh