summaryrefslogtreecommitdiff
path: root/toolchain/dependencies
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-08-21 15:33:33 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-08-21 15:33:33 +0000
commite99518277a04f0e8cf5054a6d305b2d859a59b25 (patch)
tree911a013f8d6703da67a94c809252d3f3b5414b93 /toolchain/dependencies
parent1afb8226cbaf011f81158b63c2c169ce05842d21 (diff)
- add handling of lzma for the host (unconditionally for now)
- remove non-working attempt to install an lzma to the host via sudo
Diffstat (limited to 'toolchain/dependencies')
-rwxr-xr-xtoolchain/dependencies/check-host-lzma.sh13
-rw-r--r--toolchain/dependencies/dependencies.mk2
2 files changed, 14 insertions, 1 deletions
diff --git a/toolchain/dependencies/check-host-lzma.sh b/toolchain/dependencies/check-host-lzma.sh
new file mode 100755
index 000000000..34e8f0379
--- /dev/null
+++ b/toolchain/dependencies/check-host-lzma.sh
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+ok=""
+
+for bin in /usr/bin/lzma $LZMA
+do
+# TODO: add check for proper functionality here..
+ $bin --version > /dev/null 2>&1 && ok="$bin"
+ if test "x$ok" != "x" ; then
+ break
+ fi
+done
+echo "$ok"
diff --git a/toolchain/dependencies/dependencies.mk b/toolchain/dependencies/dependencies.mk
index 992f91461..b18ffc050 100644
--- a/toolchain/dependencies/dependencies.mk
+++ b/toolchain/dependencies/dependencies.mk
@@ -5,7 +5,7 @@
#
######################################################################
-dependencies: host-sed
+dependencies: host-sed host-lzma
@HOSTCC="$(firstword $(HOSTCC))" MAKE="$(MAKE)" \
HOST_SED_DIR="$(HOST_SED_DIR)" \
$(TOPDIR)/toolchain/dependencies/dependencies.sh