summaryrefslogtreecommitdiff
path: root/toolchain/external-toolchain
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-31 20:49:59 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-31 20:49:59 +0000
commit59f084017e1d72471dcf4af4122b743cf60cbccb (patch)
treefb0b259b4cc2f569b57c45fe2b89cf830a03f008 /toolchain/external-toolchain
parentc1bb025dffd1103a89fdee0debda4079015c4054 (diff)
Change binary toolchain configuration, so
that the options become visible just below the config, instead of at bottom of screen Create a more useful default as toolchain path. Allow generation of a script which sets up paths to a binary toolchain generated by buildroot.
Diffstat (limited to 'toolchain/external-toolchain')
-rw-r--r--toolchain/external-toolchain/Config.in.25
-rw-r--r--toolchain/external-toolchain/ext-tool.mk1
2 files changed, 5 insertions, 1 deletions
diff --git a/toolchain/external-toolchain/Config.in.2 b/toolchain/external-toolchain/Config.in.2
index 489558c0f..bf3f75dd4 100644
--- a/toolchain/external-toolchain/Config.in.2
+++ b/toolchain/external-toolchain/Config.in.2
@@ -3,9 +3,12 @@
if BR2_TOOLCHAIN_EXTERNAL
config BR2_TOOLCHAIN_EXTERNAL_PATH
string "External toolchain path"
- default "/path/to/staging_dir/usr"
+ default "$(GCCROOT)"
help
Path to where the external toolchain is installed.
+ Either define GCCROOT in your environment
+ or an absolute path like:
+ "/path/to/staging_dir/usr"
config BR2_TOOLCHAIN_EXTERNAL_PREFIX
string "External toolchain prefix"
diff --git a/toolchain/external-toolchain/ext-tool.mk b/toolchain/external-toolchain/ext-tool.mk
index 1c9197b95..857dec3af 100644
--- a/toolchain/external-toolchain/ext-tool.mk
+++ b/toolchain/external-toolchain/ext-tool.mk
@@ -60,3 +60,4 @@ $(TARGET_DIR)/lib/$(strip $(subst ",, $(BR2_TOOLCHAIN_EXTERNAL_LIB_C))):
$(call copy_toolchain_lib_root, $$libs, /lib, $(BR2_TOOLCHAIN_EXTERNAL_STRIP)); \
done
$(call copy_toolchain_sysroot)
+