summaryrefslogtreecommitdiff
path: root/toolchain/gcc/gcc-uclibc-4.x.mk
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-05-02 17:38:27 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-05-02 23:12:30 +0200
commit1db3939ad91e88d420bc8983b4708ee65d3c91e2 (patch)
tree0019b35ce889f8439fa7e4cf14437a979bcd2998 /toolchain/gcc/gcc-uclibc-4.x.mk
parent28cdaaee5236d0cbe3a6afde808f5eef260e7c33 (diff)
toolchain: update gcc snapshot version
* Make mpc mandatory since we are probably building bleeding-edge * Change snapshot naming convention to match the source Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/gcc/gcc-uclibc-4.x.mk')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 9b8bf685c..712361549 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -141,6 +141,17 @@ endif
GCC_HOST_PREREQ += host-mpc
endif
+# GCC snapshot prerequisites
+# Since we don't know and it can be quite new just ask for everything known
+ifneq ($(GCC_SNAP_DATE),)
+GCC_WITH_HOST_MPC = --with-mpc=$(HOST_DIR)/usr
+GCC_TARGET_PREREQ += mpc
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
+HOST_SOURCE += host-mpc-source
+endif
+GCC_HOST_PREREQ += host-mpc
+endif
+
ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
GCC_SHARED_LIBGCC:=--enable-shared
else