summaryrefslogtreecommitdiff
path: root/toolchain/gcc/gcc-uclibc-4.x.mk
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-04-13 09:44:45 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2012-04-15 11:13:27 +0200
commitb4a8ae3e8cc9f5a7b0b4b6f7004c51e661dcc456 (patch)
tree25e7a8c9848727a8303c96f3f64f0810b0f8ea48 /toolchain/gcc/gcc-uclibc-4.x.mk
parentf4f4172a4191a3a4e47a49bbd86343c03237ac0e (diff)
toolchain/gcc: add 4.7.x series
Add gcc 4.7.0 to the toolchain options. [Peter: drop 0001-toolchain-gcc-add-4.7.x-series.txt] Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/gcc/gcc-uclibc-4.x.mk')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index d9547fbfb..ae734e88b 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -120,6 +120,16 @@ endif
GCC_HOST_PREREQ += host-mpc
endif
+# GCC 4.7.x prerequisites
+ifeq ($(findstring x4.7.,x$(GCC_VERSION)),x4.7.)
+GCC_WITH_HOST_MPC = --with-mpc=$(HOST_DIR)/usr
+GCC_TARGET_PREREQ += mpc
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
+HOST_SOURCE += host-mpc-source
+endif
+GCC_HOST_PREREQ += host-mpc
+endif
+
# GCC snapshot prerequisites
# Since we don't know and it can be quite new just ask for everything known
ifneq ($(GCC_SNAP_DATE),)