summaryrefslogtreecommitdiff
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-03-02 07:30:26 +0000
committerEric Andersen <andersen@codepoet.org>2005-03-02 07:30:26 +0000
commit8cbab86501e43cefa3ca30e55654740878d32114 (patch)
tree99060fd9c3898d17cc6b75dc813cf67e96864e76 /toolchain/gcc
parente076bd4b3392bf429e16aab1fa1711fab6f345c9 (diff)
simplify target language selection to remove nasty nested ifeq
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk16
1 files changed, 10 insertions, 6 deletions
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index fd084b29b..5aae70940 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -39,14 +39,18 @@ GCC_STRIP_HOST_BINARIES:=true
#
#############################################################
-ifeq ($(BR2_INSTALL_LIBGCJ),y)
-TARGET_LANGUAGES:=c,c++,java
-else
-ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
-TARGET_LANGUAGES:=c,c++
-else
TARGET_LANGUAGES:=c
+
+ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
+TARGET_LANGUAGES:=$(TARGET_LANGUAGES),c++
endif
+
+ifeq ($(BR2_INSTALL_LIBGCJ),y)
+TARGET_LANGUAGES:=$(TARGET_LANGUAGES),java
+endif
+
+ifeq ($(BR2_INSTALL_OBJC),y)
+TARGET_LANGUAGES:=$(TARGET_LANGUAGES),objc
endif
#############################################################