summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-12-27 21:33:46 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-27 21:33:46 +0100
commit48e9541fd5db34fce1de004805f3859b54d1eb89 (patch)
treeefdad20f2fed1c6cef712a56b99a6cff7a9a6446 /toolchain
parentd4f63946c68da03da9fa9a316e194eede5af961a (diff)
parent960d268b25f61c407056c2eba946612a38d7de9f (diff)
Merge branch 'for-2011.02/dl-tools' of git://git.busybox.net/~tpetazzoni/git/buildroot
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/dependencies/dependencies.mk7
-rwxr-xr-xtoolchain/dependencies/dependencies.sh2
2 files changed, 8 insertions, 1 deletions
diff --git a/toolchain/dependencies/dependencies.mk b/toolchain/dependencies/dependencies.mk
index 89ffd8823..13604f092 100644
--- a/toolchain/dependencies/dependencies.mk
+++ b/toolchain/dependencies/dependencies.mk
@@ -10,9 +10,16 @@ ifeq ($(BR2_STRIP_sstrip),y)
DEPENDENCIES_HOST_PREREQ+=sstrip_host
endif
+# Remove duplicate entries from $(DL_TOOLS_DEPENDENCIES)
+DL_TOOLS = \
+ $(findstring svn,$(DL_TOOLS_DEPENDENCIES)) \
+ $(findstring git,$(DL_TOOLS_DEPENDENCIES)) \
+ $(findstring bzr,$(DL_TOOLS_DEPENDENCIES))
+
dependencies: $(DEPENDENCIES_HOST_PREREQ)
@HOSTCC="$(firstword $(HOSTCC))" MAKE="$(MAKE)" \
CONFIG_FILE="$(CONFIG_DIR)/.config" \
+ DL_TOOLS="$(DL_TOOLS)" \
$(TOPDIR)/toolchain/dependencies/dependencies.sh
dependencies-source:
diff --git a/toolchain/dependencies/dependencies.sh b/toolchain/dependencies/dependencies.sh
index a152d4b8c..c5552cae0 100755
--- a/toolchain/dependencies/dependencies.sh
+++ b/toolchain/dependencies/dependencies.sh
@@ -132,7 +132,7 @@ if ! $SHELL --version 2>&1 | grep -q '^GNU bash'; then
fi;
# Check that a few mandatory programs are installed
-for prog in awk bison flex msgfmt makeinfo patch gzip bzip2 perl tar wget cpio python svn unzip ; do
+for prog in awk bison flex msgfmt makeinfo patch gzip bzip2 perl tar wget cpio python unzip ${DL_TOOLS} ; do
if ! which $prog > /dev/null ; then
/bin/echo -e "\nYou must install '$prog' on your build machine";
if test $prog = "makeinfo" ; then