summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-05 18:59:00 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-07-06 07:59:39 +0200
commit4b17cef16b9b82e120ea9a03481e3978a2229ac1 (patch)
treec6d060bc19e5380bae888ed1efaa301340f279af /toolchain
parentdd5ca4beb5bc62962bcc7f665749122c6ec44cbd (diff)
external-toolchain: recognize uClibc 64 bits toolchains
With uClibc 64 bits toolchain, the dynamic loader is named ld64-uClibc.so.0 and not ld-uClibc.so.0. So, this commit adjust the uClibc detection code for external toolchains. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: Yann E. MORIN <yann.morin.1998@anciens.enib.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/external-toolchain/ext-tool.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/external-toolchain/ext-tool.mk b/toolchain/external-toolchain/ext-tool.mk
index d59178116..39961843e 100644
--- a/toolchain/external-toolchain/ext-tool.mk
+++ b/toolchain/external-toolchain/ext-tool.mk
@@ -216,7 +216,7 @@ check_uclibc_feature = \
#
check_uclibc = \
SYSROOT_DIR="$(strip $1)"; \
- if ! test -f $${SYSROOT_DIR}/lib/ld-uClibc.so.* ; then \
+ if ! test -f $${SYSROOT_DIR}/lib/ld*-uClibc.so.* ; then \
echo "Incorrect selection of the C library"; \
exit -1; \
fi; \