summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-01-12 14:11:40 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-01-12 14:11:40 +0000
commit5b220b9ded7d65b240e08e7354f8b2e8e513128d (patch)
treed8010d5e6a384b5c7656ef1a3967be10bb40040e /toolchain
parent215e91f132fcd8da2b90a0e1635d6f4f67084727 (diff)
toolchain/uclibc: propagate mips mips32r2 variant setting to uclibc
0.9.30 supports MIPS_ISA_MIPS32R2, so use it if mips32r2 variant is selected.
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/uClibc/uclibc.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index 37409262d..fe055cea1 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -185,6 +185,7 @@ ifeq ($(UCLIBC_TARGET_ARCH),mips)
/bin/echo "# CONFIG_MIPS_ISA_3 is not set"; \
/bin/echo "# CONFIG_MIPS_ISA_4 is not set"; \
/bin/echo "# CONFIG_MIPS_ISA_MIPS32 is not set"; \
+ /bin/echo "# CONFIG_MIPS_ISA_MIPS32R2 is not set"; \
/bin/echo "# CONFIG_MIPS_ISA_MIPS64 is not set"; \
) >> $(UCLIBC_DIR)/.oldconfig
ifeq ($(BR2_MIPS_OABI),y)
@@ -209,10 +210,10 @@ ifeq ($(BR2_mips_4),y)
$(SED) 's/.*\(CONFIG_MIPS_ISA_4\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
endif
ifeq ($(BR2_mips_32),y)
- $(SED) 's/.*\(CONFIG_MIPS_ISA_MIPS32\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
+ $(SED) 's/.*\(CONFIG_MIPS_ISA_MIPS32\)[^R].*/\1=y/' $(UCLIBC_DIR)/.oldconfig
endif
ifeq ($(BR2_mips_32r2),y)
- $(SED) 's/.*\(CONFIG_MIPS_ISA_MIPS32\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
+ $(SED) 's/.*\(CONFIG_MIPS_ISA_MIPS32R2\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
endif
ifeq ($(BR2_mips_64),y)
$(SED) 's/.*\(CONFIG_MIPS_ISA_MIPS64\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig