summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-07-08 10:21:16 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-07-08 10:21:16 +0200
commit74708bad1512a917a28c59646d1f9491f6fe9ea6 (patch)
tree7f3bf126d8251e99dda6da042be1fe016d59e3c3 /toolchain
parent049cf426e32d6f789439d0d06905c977bfd25c02 (diff)
parentd0169fda2144ef5dfe25e801d58a227ed119a38c (diff)
Merge branch 'misc-fixes' of git://git.busybox.net/~tpetazzoni/git/buildroot
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/Makefile.in2
-rw-r--r--toolchain/external-toolchain/ext-tool.mk16
-rw-r--r--toolchain/gdb/gdb.mk4
-rw-r--r--toolchain/uClibc/uClibc-0.9.30.config2
-rw-r--r--toolchain/uClibc/uClibc-0.9.31.config2
5 files changed, 13 insertions, 13 deletions
diff --git a/toolchain/Makefile.in b/toolchain/Makefile.in
index 5d0e5a1c2..e5fae1f56 100644
--- a/toolchain/Makefile.in
+++ b/toolchain/Makefile.in
@@ -15,8 +15,6 @@ BR2_SYSROOT_TARGET_DESTDIR=DESTDIR=$(TARGET_DIR)/
BR2_CONFIGURE_DEVEL_SYSROOT=--with-sysroot=$(TOOLCHAIN_DIR)/uClibc_dev/
BR2_CONFIGURE_STAGING_SYSROOT=--with-sysroot=$(STAGING_DIR)
BR2_CONFIGURE_BUILD_TOOLS=--with-build-time-tools=$(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/bin
-BR2_SYSROOT=--sysroot=$(STAGING_DIR)/
-BR2_ISYSROOT=-isysroot $(STAGING_DIR)
# gcc has a bunch of needed stuff....
include toolchain/gcc/Makefile.in
diff --git a/toolchain/external-toolchain/ext-tool.mk b/toolchain/external-toolchain/ext-tool.mk
index 7ca138b9d..9ad1e3165 100644
--- a/toolchain/external-toolchain/ext-tool.mk
+++ b/toolchain/external-toolchain/ext-tool.mk
@@ -262,7 +262,8 @@ check_arm_abi = \
# Check that the external toolchain supports C++
#
check_cplusplus = \
- if ! test -x $(TARGET_CXX) ; then \
+ $(TARGET_CXX) -v > /dev/null 2>&1 ; \
+ if test $$? -ne 0 ; then \
echo "BR2_INSTALL_LIBSTDCPP is selected but C++ support not available in external toolchain" ; \
exit 1 ; \
fi ; \
@@ -271,8 +272,9 @@ check_cplusplus = \
# Check that the cross-compiler given in the configuration exists
#
check_cross_compiler_exists = \
- if ! test -x $(TARGET_CC) ; then \
- echo "Cannot find cross-compiler $(TARGET_CC)" ; \
+ $(TARGET_CC) -v > /dev/null 2>&1 ; \
+ if test $$? -ne 0 ; then \
+ echo "Cannot execute cross-compiler '$(TARGET_CC)'" ; \
exit 1 ; \
fi ; \
@@ -301,9 +303,10 @@ endif # ! no threads
# could select a multilib variant as we want the "main" sysroot, which
# contains all variants of the C library in the case of multilib
# toolchains.
-SYSROOT_DIR=$(shell $(TARGET_CC) -print-sysroot 2>/dev/null)
+TARGET_CC_NO_SYSROOT=$(filter-out --sysroot=%,$(TARGET_CC))
+SYSROOT_DIR=$(shell $(TARGET_CC_NO_SYSROOT) -print-sysroot 2>/dev/null)
ifeq ($(SYSROOT_DIR),)
-SYSROOT_DIR=$(shell readlink -f $$(LANG=C $(TARGET_CC) -print-file-name=libc.a |sed -r -e 's:usr/lib/libc\.a::;'))
+SYSROOT_DIR=$(shell readlink -f $$(LANG=C $(TARGET_CC_NO_SYSROOT) -print-file-name=libc.a |sed -r -e 's:usr/lib/libc\.a::;'))
endif
# Now, find if the toolchain specifies a sub-directory for the
@@ -315,8 +318,7 @@ endif
# subdirectory, in the main SYSROOT_DIR, that corresponds to the
# selected architecture variant. ARCH_SYSROOT_DIR will contain the
# full path to this location.
-TARGET_CFLAGS_NO_SYSROOT=$(filter-out --sysroot=%,$(TARGET_CFLAGS))
-ARCH_SUBDIR=$(shell $(TARGET_CC) $(TARGET_CFLAGS_NO_SYSROOT) -print-multi-directory)
+ARCH_SUBDIR=$(shell $(TARGET_CC_NO_SYSROOT) $(TARGET_CFLAGS) -print-multi-directory)
ARCH_SYSROOT_DIR=$(SYSROOT_DIR)/$(ARCH_SUBDIR)
$(STAMP_DIR)/ext-toolchain-installed:
diff --git a/toolchain/gdb/gdb.mk b/toolchain/gdb/gdb.mk
index 5725067c2..c4fef8946 100644
--- a/toolchain/gdb/gdb.mk
+++ b/toolchain/gdb/gdb.mk
@@ -95,7 +95,7 @@ endif
$(GDB_TARGET_DIR)/gdb/gdb: $(GDB_TARGET_DIR)/.configured
# force ELF support since it fails due to BFD linking problems
gdb_cv_var_elf=yes \
- $(MAKE) CC=$(TARGET_CC) MT_CFLAGS="$(TARGET_CFLAGS)" \
+ $(MAKE) CC="$(TARGET_CC)" MT_CFLAGS="$(TARGET_CFLAGS)" \
-C $(GDB_TARGET_DIR)
$(STRIPCMD) $(GDB_TARGET_DIR)/gdb/gdb
@@ -150,7 +150,7 @@ $(GDB_SERVER_DIR)/.configured: $(GDB_DIR)/.unpacked
touch $@
$(GDB_SERVER_DIR)/gdbserver: $(GDB_SERVER_DIR)/.configured
- $(MAKE) CC=$(TARGET_CC) MT_CFLAGS="$(TARGET_CFLAGS)" \
+ $(MAKE) CC="$(TARGET_CC)" MT_CFLAGS="$(TARGET_CFLAGS)" \
-C $(GDB_SERVER_DIR)
$(STRIPCMD) $(GDB_SERVER_DIR)/gdbserver
diff --git a/toolchain/uClibc/uClibc-0.9.30.config b/toolchain/uClibc/uClibc-0.9.30.config
index c8efe18ec..2202b9e14 100644
--- a/toolchain/uClibc/uClibc-0.9.30.config
+++ b/toolchain/uClibc/uClibc-0.9.30.config
@@ -87,7 +87,7 @@ UCLIBC_HAS___PROGNAME=y
UCLIBC_HAS_PTY=y
ASSUME_DEVPTS=y
UNIX98PTY_ONLY=y
-# UCLIBC_HAS_GETPT is not set
+UCLIBC_HAS_GETPT=y
UCLIBC_HAS_TM_EXTENSIONS=y
UCLIBC_HAS_TZ_CACHING=y
UCLIBC_HAS_TZ_FILE=y
diff --git a/toolchain/uClibc/uClibc-0.9.31.config b/toolchain/uClibc/uClibc-0.9.31.config
index 04d6895c0..60b462806 100644
--- a/toolchain/uClibc/uClibc-0.9.31.config
+++ b/toolchain/uClibc/uClibc-0.9.31.config
@@ -94,7 +94,7 @@ UCLIBC_HAS_SHADOW=y
UCLIBC_HAS_PTY=y
ASSUME_DEVPTS=y
UNIX98PTY_ONLY=y
-# UCLIBC_HAS_GETPT is not set
+UCLIBC_HAS_GETPT=y
UCLIBC_HAS_LIBUTIL=y
UCLIBC_HAS_TM_EXTENSIONS=y
UCLIBC_HAS_TZ_CACHING=y