summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2012-03-13 23:30:00 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-03-15 00:00:57 +0100
commita22dc0f2302c1879ad3bad4dc41348181c5807ef (patch)
treef4de5e0da715b8ee168db0d99a0289ad54f28e35 /toolchain
parent39bd61c6f30e3d9548b5928488fcd9ccfb3fda70 (diff)
ext-toolchain: Automatically set -m64 if the architecture is x86_64
Without the -m64, choosing the x86_64 architecture with a Sourcery external toolchain will result in a 32-bit rootfs. Also simplified the help text to reflect this change. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/toolchain-external/Config.in34
-rw-r--r--toolchain/toolchain-external/ext-tool.mk4
-rw-r--r--toolchain/toolchain-external/ext-toolchain-wrapper.c3
3 files changed, 25 insertions, 16 deletions
diff --git a/toolchain/toolchain-external/Config.in b/toolchain/toolchain-external/Config.in
index 7f57952e0..24cad9c0e 100644
--- a/toolchain/toolchain-external/Config.in
+++ b/toolchain/toolchain-external/Config.in
@@ -371,14 +371,15 @@ config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_X86_201109
binutils 2.21.53, glibc 2.13, gdb 7.2.50 and kernel headers
3.0.1. It has support for the following variants:
- Intel Pentium 4, glibc, 32 bits
- Default, nothing special to do.
- - Intel Atom, glibc, 32 bits
- Select an Atom core
- - Intel Xeon, glibc, 64 bits
- Set BR2_TARGET_OPTIMIZATION to -m64
- - Intel Core 2, glibc, 64 bits
- Select a Core 2 core
- Set BR2_TARGET_OPTIMIZATION to -m64
+ Default for x86, nothing special to do.
+ - Intel Atom, glibc, 32 bits
+ Select an Atom core
+ - Intel Xeon, glibc, 64 bits
+ Default for x86_64, nothing special to do.
+ - Intel Core 2, glibc, 64 bits
+ Select a Core 2 core
+ Other architecture variants (beyond Pentium-4/Xeon) are
+ supported as well, but glibc is not optimised for it.
config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_X86_201009
bool "Sourcery CodeBench x86/x86_64 2010.09"
@@ -391,14 +392,15 @@ config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_X86_201009
binutils 2.20, glibc 2.11, gdb 7.2.50 and kernel headers
2.6.35.2. It has support for the following variants:
- Intel Pentium 4, glibc, 32 bits
- Default, nothing special to do.
- - Intel Atom, glibc, 32 bits
- Select an Atom core
- - Intel Xeon, glibc, 64 bits
- Set BR2_TARGET_OPTIMIZATION to -m64
- - Intel Core 2, glibc, 64 bits
- Select a Core 2 core
- Set BR2_TARGET_OPTIMIZATION to -m64
+ Default for x86, nothing special to do.
+ - Intel Atom, glibc, 32 bits
+ Select an Atom core
+ - Intel Xeon, glibc, 64 bits
+ Default for x86_64, nothing special to do.
+ - Intel Core 2, glibc, 64 bits
+ Select a Core 2 core
+ Other architecture variants (beyond Pentium-4/Xeon) are
+ supported as well, but glibc is not optimised for it.
config BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2011R1
bool "Blackfin.uclinux.org 2011R1-RC4"
diff --git a/toolchain/toolchain-external/ext-tool.mk b/toolchain/toolchain-external/ext-tool.mk
index 01ab91fed..dbd39b068 100644
--- a/toolchain/toolchain-external/ext-tool.mk
+++ b/toolchain/toolchain-external/ext-tool.mk
@@ -133,6 +133,10 @@ CC_TARGET_ABI_:=$(call qstrip,$(BR2_GCC_TARGET_ABI))
# march/mtune/floating point mode needs to be passed to the external toolchain
# to select the right multilib variant
+ifeq ($(BR2_x86_64),y)
+TOOLCHAIN_EXTERNAL_CFLAGS += -m64
+TOOLCHAIN_EXTERNAL_WRAPPER_ARGS += -DBR_64
+endif
ifneq ($(CC_TARGET_TUNE_),)
TOOLCHAIN_EXTERNAL_CFLAGS += -mtune=$(CC_TARGET_TUNE_)
TOOLCHAIN_EXTERNAL_WRAPPER_ARGS += -DBR_TUNE='"$(CC_TARGET_TUNE_)"'
diff --git a/toolchain/toolchain-external/ext-toolchain-wrapper.c b/toolchain/toolchain-external/ext-toolchain-wrapper.c
index 719f13bd1..82595eaa7 100644
--- a/toolchain/toolchain-external/ext-toolchain-wrapper.c
+++ b/toolchain/toolchain-external/ext-toolchain-wrapper.c
@@ -40,6 +40,9 @@ static char *predef_args[] = {
#ifdef BR_VFPFLOAT
"-mfpu=vfp",
#endif /* BR_VFPFLOAT */
+#ifdef BR_64
+ "-m64",
+#endif
#ifdef BR_ADDITIONAL_CFLAGS
BR_ADDITIONAL_CFLAGS
#endif