summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-07-14 09:28:37 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-15 00:57:42 +0200
commitb6ebb7fd1bd778709c3acb10b96a43e6bd863dae (patch)
tree61c88795cf6950a909802600a38ad8c6b5a53711 /toolchain
parent9308ac18687c016f654598ac55b15a9957562956 (diff)
toolchain/mips: kill EABI and fix N32
MIPS EABI is a bare-metal ABI so remove it. Also fix uClibc to really work with N32 ABI, which used the EABI knob previously. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/uClibc/uclibc.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index f40fe365b..9d0b6db94 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -158,7 +158,7 @@ ifeq ($(UCLIBC_TARGET_ARCH),mips)
ifeq ($(BR2_MIPS_OABI),y)
$(SED) 's/.*\(CONFIG_MIPS_O32_ABI\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
endif
-ifeq ($(BR2_MIPS_EABI),y)
+ifeq ($(BR2_MIPS_ABI32),y)
$(SED) 's/.*\(CONFIG_MIPS_N32_ABI\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
endif
ifeq ($(BR2_MIPS_ABI64),y)