summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-12-14 11:19:34 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-12-14 23:54:42 +0100
commitf18480603222ebc9996abc43793082012fb18ab0 (patch)
tree37a953b9825458bb3346c34dbcda5167fed07734 /toolchain
parent8bbb56dd9109354f66e428b4a0f83d637851643b (diff)
binutils: add avr32 special version
* Add a new binutils version 2.18-avr32-1.0.1 to the Config.in * Use a different site to download avr32 binutils version in binutils.mk * Only apply patches from the patch directory if it exists in binutils.mk Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/binutils/Config.in5
-rw-r--r--toolchain/binutils/binutils.mk5
2 files changed, 10 insertions, 0 deletions
diff --git a/toolchain/binutils/Config.in b/toolchain/binutils/Config.in
index b892b6f74..4405bcb49 100644
--- a/toolchain/binutils/Config.in
+++ b/toolchain/binutils/Config.in
@@ -24,6 +24,10 @@ choice
depends on BR2_DEPRECATED
bool "binutils 2.18.50.0.9"
+ config BR2_BINUTILS_VERSION_2_18_AVR32_1_0_1
+ depends on BR2_avr32
+ bool "binutils 2.18-avr32-1.0.1"
+
config BR2_BINUTILS_VERSION_2_19
depends on !BR2_avr32 && !BR2_nios2
depends on BR2_DEPRECATED
@@ -46,6 +50,7 @@ config BR2_BINUTILS_VERSION
default "2.17" if BR2_BINUTILS_VERSION_2_17
default "2.18" if BR2_BINUTILS_VERSION_2_18
default "2.18.50.0.9" if BR2_BINUTILS_VERSION_2_18_50_0_9
+ default "2.18-avr32-1.0.1" if BR2_BINUTILS_VERSION_2_18_AVR32_1_0_1
default "2.19" if BR2_BINUTILS_VERSION_2_19
default "2.19.1" if BR2_BINUTILS_VERSION_2_19_1
default "2.20" if BR2_BINUTILS_VERSION_2_20
diff --git a/toolchain/binutils/binutils.mk b/toolchain/binutils/binutils.mk
index 8cddf2d50..38bee9ecc 100644
--- a/toolchain/binutils/binutils.mk
+++ b/toolchain/binutils/binutils.mk
@@ -22,6 +22,9 @@ endif
ifeq ($(BINUTILS_VERSION),2.17)
BINUTILS_SITE:=$(BR2_GNU_MIRROR)/binutils/
endif
+ifeq ($(findstring avr32,$(BINUTILS_VERSION)),avr32)
+BINUTILS_SITE:=ftp://www.at91.com/pub/buildroot/
+endif
# We do not rely on the host's gmp/mpfr but use a known working one
BINUTILS_HOST_PREREQ:=
@@ -79,7 +82,9 @@ $(BINUTILS_DIR)/.unpacked: $(DL_DIR)/$(BINUTILS_SOURCE)
binutils-patched: $(BINUTILS_DIR)/.patched
$(BINUTILS_DIR)/.patched: $(BINUTILS_DIR)/.unpacked
# Apply appropriate binutils patches.
+ifneq ($(wildcard $(BINUTILS_PATCH_DIR)),)
toolchain/patch-kernel.sh $(BINUTILS_DIR) $(BINUTILS_PATCH_DIR) \*.patch $(BINUTILS_PATCH_EXTRA)
+endif
touch $@
$(BINUTILS_DIR1)/.configured: $(BINUTILS_DIR)/.patched