summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-06-17 12:54:36 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-06-17 12:54:36 +0000
commit759e150633f9718bd87c84bacdadc62e22ce8817 (patch)
tree9f888e926c682533e2e28b47dc87ce8d7c5ec414 /toolchain
parentebd3916b5961d71d0121d365a772af59543f29d4 (diff)
toolchain/gcc-3.x: strip cross libgcc / libstdc++ with cross-strip, not host.
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index 58afa9261..cc4bcadb2 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -336,12 +336,12 @@ ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
rm -rf $(TARGET_DIR)/usr/lib/libgcc_s*.so*
-cp -dpf $(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/lib/libgcc_s* \
$(TARGET_DIR)/lib/
- -strip --strip-unneeded $(TARGET_DIR)/lib/libgcc_s*
+ -$(STRIPCMD) --strip-unneeded $(TARGET_DIR)/lib/libgcc_s*
endif
ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
-cp -dpf $(STAGING_DIR)/lib/libstdc++.so* $(TARGET_DIR)/usr/lib/
- -strip --strip-unneeded $(TARGET_DIR)/usr/lib/libstdc++.so*
+ -$(STRIPCMD) --strip-unneeded $(TARGET_DIR)/usr/lib/libstdc++.so*
endif
endif
ifeq ($(BR2_INSTALL_LIBGCJ),y)