summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-11 05:28:08 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-11 05:28:08 +0000
commitabcdf35a868d85072204186bac9a821d47307339 (patch)
tree02f8428b36abacc51ba66f2e53b2f3ac639a2568 /toolchain
parent3c9bf1fc1fa3352f9bc1345f7888d68aaaa6a4fd (diff)
use the shared gnuconfig package to update config.sub files rather than patching them
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/3.3.5/100-uclibc-conf.patch22
-rw-r--r--toolchain/gcc/3.3.6/100-uclibc-conf.patch22
-rw-r--r--toolchain/gcc/4.0.0/100-uclibc-conf.patch40
-rw-r--r--toolchain/gcc/4.0.1/100-uclibc-conf.patch40
-rw-r--r--toolchain/gcc/4.0.2/100-uclibc-conf.patch40
-rw-r--r--toolchain/gcc/4.1.0/100-uclibc-conf.patch40
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk1
7 files changed, 1 insertions, 204 deletions
diff --git a/toolchain/gcc/3.3.5/100-uclibc-conf.patch b/toolchain/gcc/3.3.5/100-uclibc-conf.patch
index 4bbe21b7a..c5d76d940 100644
--- a/toolchain/gcc/3.3.5/100-uclibc-conf.patch
+++ b/toolchain/gcc/3.3.5/100-uclibc-conf.patch
@@ -35,28 +35,6 @@ diff -urN gcc-3.3.3-dist/boehm-gc/configure gcc-3.3.3/boehm-gc/configure
netbsd*)
if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
-diff -urN gcc-3.3.3-dist/config.sub gcc-3.3.3/config.sub
---- gcc-3.3.3-dist/config.sub 2003-01-30 17:25:36.000000000 -0600
-+++ gcc-3.3.3/config.sub 2004-08-12 04:47:51.000000000 -0500
-@@ -118,7 +118,7 @@
- # Here we must recognize all the valid KERNEL-OS combinations.
- maybe_os=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\2/'`
- case $maybe_os in
-- nto-qnx* | linux-gnu* | freebsd*-gnu* | netbsd*-gnu* | storm-chaos* | os2-emx* | rtmk-nova*)
-+ nto-qnx* | linux-gnu* | linux-uclibc* | freebsd*-gnu* | netbsd*-gnu* | storm-chaos* | os2-emx* | rtmk-nova*)
- os=-$maybe_os
- basic_machine=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\1/'`
- ;;
-@@ -1112,7 +1112,8 @@
- | -udi* | -eabi* | -lites* | -ieee* | -go32* | -aux* \
- | -chorusos* | -chorusrdb* \
- | -cygwin* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
-- | -mingw32* | -linux-gnu* | -uxpv* | -beos* | -mpeix* | -udk* \
-+ | -mingw32* | -linux-gnu* | -linux-uclibc* \
-+ | -uxpv* | -beos* | -mpeix* | -udk* \
- | -interix* | -uwin* | -mks* | -rhapsody* | -darwin* | -opened* \
- | -openstep* | -oskit* | -conix* | -pw32* | -nonstopux* \
- | -storm-chaos* | -tops10* | -tenex* | -tops20* | -its* \
diff -urN gcc-3.3.3-dist/gcc/config/arm/linux-elf.h gcc-3.3.3/gcc/config/arm/linux-elf.h
--- gcc-3.3.3-dist/gcc/config/arm/linux-elf.h 2003-09-16 10:39:23.000000000 -0500
+++ gcc-3.3.3/gcc/config/arm/linux-elf.h 2004-08-12 04:47:51.000000000 -0500
diff --git a/toolchain/gcc/3.3.6/100-uclibc-conf.patch b/toolchain/gcc/3.3.6/100-uclibc-conf.patch
index 4bbe21b7a..c5d76d940 100644
--- a/toolchain/gcc/3.3.6/100-uclibc-conf.patch
+++ b/toolchain/gcc/3.3.6/100-uclibc-conf.patch
@@ -35,28 +35,6 @@ diff -urN gcc-3.3.3-dist/boehm-gc/configure gcc-3.3.3/boehm-gc/configure
netbsd*)
if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
-diff -urN gcc-3.3.3-dist/config.sub gcc-3.3.3/config.sub
---- gcc-3.3.3-dist/config.sub 2003-01-30 17:25:36.000000000 -0600
-+++ gcc-3.3.3/config.sub 2004-08-12 04:47:51.000000000 -0500
-@@ -118,7 +118,7 @@
- # Here we must recognize all the valid KERNEL-OS combinations.
- maybe_os=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\2/'`
- case $maybe_os in
-- nto-qnx* | linux-gnu* | freebsd*-gnu* | netbsd*-gnu* | storm-chaos* | os2-emx* | rtmk-nova*)
-+ nto-qnx* | linux-gnu* | linux-uclibc* | freebsd*-gnu* | netbsd*-gnu* | storm-chaos* | os2-emx* | rtmk-nova*)
- os=-$maybe_os
- basic_machine=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\1/'`
- ;;
-@@ -1112,7 +1112,8 @@
- | -udi* | -eabi* | -lites* | -ieee* | -go32* | -aux* \
- | -chorusos* | -chorusrdb* \
- | -cygwin* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
-- | -mingw32* | -linux-gnu* | -uxpv* | -beos* | -mpeix* | -udk* \
-+ | -mingw32* | -linux-gnu* | -linux-uclibc* \
-+ | -uxpv* | -beos* | -mpeix* | -udk* \
- | -interix* | -uwin* | -mks* | -rhapsody* | -darwin* | -opened* \
- | -openstep* | -oskit* | -conix* | -pw32* | -nonstopux* \
- | -storm-chaos* | -tops10* | -tenex* | -tops20* | -its* \
diff -urN gcc-3.3.3-dist/gcc/config/arm/linux-elf.h gcc-3.3.3/gcc/config/arm/linux-elf.h
--- gcc-3.3.3-dist/gcc/config/arm/linux-elf.h 2003-09-16 10:39:23.000000000 -0500
+++ gcc-3.3.3/gcc/config/arm/linux-elf.h 2004-08-12 04:47:51.000000000 -0500
diff --git a/toolchain/gcc/4.0.0/100-uclibc-conf.patch b/toolchain/gcc/4.0.0/100-uclibc-conf.patch
index d6eda4c81..d9d62f4fa 100644
--- a/toolchain/gcc/4.0.0/100-uclibc-conf.patch
+++ b/toolchain/gcc/4.0.0/100-uclibc-conf.patch
@@ -476,43 +476,3 @@ diff -urN gcc-4.0.0-dist/zlib/configure gcc-4.0.0/zlib/configure
netbsd* | knetbsd*-gnu)
if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
-diff -urN gcc-4.0.0.orig/config.sub gcc-4.0.0/config.sub
---- gcc-4.0.0.orig/config.sub 2005-01-18 03:20:48.000000000 +0200
-+++ gcc-4.0.0/config.sub 2005-05-02 13:46:44.643407037 +0300
-@@ -260,7 +260,7 @@
- | pdp10 | pdp11 | pj | pjl \
- | powerpc | powerpc64 | powerpc64le | powerpcle | ppcbe \
- | pyramid \
-- | sh | sh[1234] | sh[23]e | sh[34]eb | shbe | shle | sh[1234]le | sh3ele \
-+ | sh | sh[1234]* | sh[23]e | sh[34]eb | shbe | shle | sh[1234]le | sh3ele \
- | sh64 | sh64le \
- | sparc | sparc64 | sparc86x | sparclet | sparclite | sparcv8 | sparcv9 | sparcv9b \
- | strongarm \
-@@ -334,7 +334,7 @@
- | powerpc-* | powerpc64-* | powerpc64le-* | powerpcle-* | ppcbe-* \
- | pyramid-* \
- | romp-* | rs6000-* \
-- | sh-* | sh[1234]-* | sh[23]e-* | sh[34]eb-* | shbe-* \
-+ | sh-* | sh[1234]*-* | sh[23]e-* | sh[34]eb-* | shbe-* \
- | shle-* | sh[1234]le-* | sh3ele-* | sh64-* | sh64le-* \
- | sparc-* | sparc64-* | sparc86x-* | sparclet-* | sparclite-* \
- | sparcv8-* | sparcv9-* | sparcv9b-* | strongarm-* | sv1-* | sx?-* \
-@@ -884,9 +884,6 @@
- basic_machine=sh-hitachi
- os=-hms
- ;;
-- sh64)
-- basic_machine=sh64-unknown
-- ;;
- sparclite-wrs | simso-wrs)
- basic_machine=sparclite-wrs
- os=-vxworks
-@@ -1086,7 +1083,7 @@
- we32k)
- basic_machine=we32k-att
- ;;
-- sh3 | sh4 | sh[34]eb | sh[1234]le | sh[23]ele)
-+ sh2* | sh3 | sh4 | sh[34]eb | sh[1234]le | sh[23]ele)
- basic_machine=sh-unknown
- ;;
- sh64)
diff --git a/toolchain/gcc/4.0.1/100-uclibc-conf.patch b/toolchain/gcc/4.0.1/100-uclibc-conf.patch
index d6eda4c81..d9d62f4fa 100644
--- a/toolchain/gcc/4.0.1/100-uclibc-conf.patch
+++ b/toolchain/gcc/4.0.1/100-uclibc-conf.patch
@@ -476,43 +476,3 @@ diff -urN gcc-4.0.0-dist/zlib/configure gcc-4.0.0/zlib/configure
netbsd* | knetbsd*-gnu)
if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
-diff -urN gcc-4.0.0.orig/config.sub gcc-4.0.0/config.sub
---- gcc-4.0.0.orig/config.sub 2005-01-18 03:20:48.000000000 +0200
-+++ gcc-4.0.0/config.sub 2005-05-02 13:46:44.643407037 +0300
-@@ -260,7 +260,7 @@
- | pdp10 | pdp11 | pj | pjl \
- | powerpc | powerpc64 | powerpc64le | powerpcle | ppcbe \
- | pyramid \
-- | sh | sh[1234] | sh[23]e | sh[34]eb | shbe | shle | sh[1234]le | sh3ele \
-+ | sh | sh[1234]* | sh[23]e | sh[34]eb | shbe | shle | sh[1234]le | sh3ele \
- | sh64 | sh64le \
- | sparc | sparc64 | sparc86x | sparclet | sparclite | sparcv8 | sparcv9 | sparcv9b \
- | strongarm \
-@@ -334,7 +334,7 @@
- | powerpc-* | powerpc64-* | powerpc64le-* | powerpcle-* | ppcbe-* \
- | pyramid-* \
- | romp-* | rs6000-* \
-- | sh-* | sh[1234]-* | sh[23]e-* | sh[34]eb-* | shbe-* \
-+ | sh-* | sh[1234]*-* | sh[23]e-* | sh[34]eb-* | shbe-* \
- | shle-* | sh[1234]le-* | sh3ele-* | sh64-* | sh64le-* \
- | sparc-* | sparc64-* | sparc86x-* | sparclet-* | sparclite-* \
- | sparcv8-* | sparcv9-* | sparcv9b-* | strongarm-* | sv1-* | sx?-* \
-@@ -884,9 +884,6 @@
- basic_machine=sh-hitachi
- os=-hms
- ;;
-- sh64)
-- basic_machine=sh64-unknown
-- ;;
- sparclite-wrs | simso-wrs)
- basic_machine=sparclite-wrs
- os=-vxworks
-@@ -1086,7 +1083,7 @@
- we32k)
- basic_machine=we32k-att
- ;;
-- sh3 | sh4 | sh[34]eb | sh[1234]le | sh[23]ele)
-+ sh2* | sh3 | sh4 | sh[34]eb | sh[1234]le | sh[23]ele)
- basic_machine=sh-unknown
- ;;
- sh64)
diff --git a/toolchain/gcc/4.0.2/100-uclibc-conf.patch b/toolchain/gcc/4.0.2/100-uclibc-conf.patch
index d6eda4c81..d9d62f4fa 100644
--- a/toolchain/gcc/4.0.2/100-uclibc-conf.patch
+++ b/toolchain/gcc/4.0.2/100-uclibc-conf.patch
@@ -476,43 +476,3 @@ diff -urN gcc-4.0.0-dist/zlib/configure gcc-4.0.0/zlib/configure
netbsd* | knetbsd*-gnu)
if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
-diff -urN gcc-4.0.0.orig/config.sub gcc-4.0.0/config.sub
---- gcc-4.0.0.orig/config.sub 2005-01-18 03:20:48.000000000 +0200
-+++ gcc-4.0.0/config.sub 2005-05-02 13:46:44.643407037 +0300
-@@ -260,7 +260,7 @@
- | pdp10 | pdp11 | pj | pjl \
- | powerpc | powerpc64 | powerpc64le | powerpcle | ppcbe \
- | pyramid \
-- | sh | sh[1234] | sh[23]e | sh[34]eb | shbe | shle | sh[1234]le | sh3ele \
-+ | sh | sh[1234]* | sh[23]e | sh[34]eb | shbe | shle | sh[1234]le | sh3ele \
- | sh64 | sh64le \
- | sparc | sparc64 | sparc86x | sparclet | sparclite | sparcv8 | sparcv9 | sparcv9b \
- | strongarm \
-@@ -334,7 +334,7 @@
- | powerpc-* | powerpc64-* | powerpc64le-* | powerpcle-* | ppcbe-* \
- | pyramid-* \
- | romp-* | rs6000-* \
-- | sh-* | sh[1234]-* | sh[23]e-* | sh[34]eb-* | shbe-* \
-+ | sh-* | sh[1234]*-* | sh[23]e-* | sh[34]eb-* | shbe-* \
- | shle-* | sh[1234]le-* | sh3ele-* | sh64-* | sh64le-* \
- | sparc-* | sparc64-* | sparc86x-* | sparclet-* | sparclite-* \
- | sparcv8-* | sparcv9-* | sparcv9b-* | strongarm-* | sv1-* | sx?-* \
-@@ -884,9 +884,6 @@
- basic_machine=sh-hitachi
- os=-hms
- ;;
-- sh64)
-- basic_machine=sh64-unknown
-- ;;
- sparclite-wrs | simso-wrs)
- basic_machine=sparclite-wrs
- os=-vxworks
-@@ -1086,7 +1083,7 @@
- we32k)
- basic_machine=we32k-att
- ;;
-- sh3 | sh4 | sh[34]eb | sh[1234]le | sh[23]ele)
-+ sh2* | sh3 | sh4 | sh[34]eb | sh[1234]le | sh[23]ele)
- basic_machine=sh-unknown
- ;;
- sh64)
diff --git a/toolchain/gcc/4.1.0/100-uclibc-conf.patch b/toolchain/gcc/4.1.0/100-uclibc-conf.patch
index d6eda4c81..d9d62f4fa 100644
--- a/toolchain/gcc/4.1.0/100-uclibc-conf.patch
+++ b/toolchain/gcc/4.1.0/100-uclibc-conf.patch
@@ -476,43 +476,3 @@ diff -urN gcc-4.0.0-dist/zlib/configure gcc-4.0.0/zlib/configure
netbsd* | knetbsd*-gnu)
if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
-diff -urN gcc-4.0.0.orig/config.sub gcc-4.0.0/config.sub
---- gcc-4.0.0.orig/config.sub 2005-01-18 03:20:48.000000000 +0200
-+++ gcc-4.0.0/config.sub 2005-05-02 13:46:44.643407037 +0300
-@@ -260,7 +260,7 @@
- | pdp10 | pdp11 | pj | pjl \
- | powerpc | powerpc64 | powerpc64le | powerpcle | ppcbe \
- | pyramid \
-- | sh | sh[1234] | sh[23]e | sh[34]eb | shbe | shle | sh[1234]le | sh3ele \
-+ | sh | sh[1234]* | sh[23]e | sh[34]eb | shbe | shle | sh[1234]le | sh3ele \
- | sh64 | sh64le \
- | sparc | sparc64 | sparc86x | sparclet | sparclite | sparcv8 | sparcv9 | sparcv9b \
- | strongarm \
-@@ -334,7 +334,7 @@
- | powerpc-* | powerpc64-* | powerpc64le-* | powerpcle-* | ppcbe-* \
- | pyramid-* \
- | romp-* | rs6000-* \
-- | sh-* | sh[1234]-* | sh[23]e-* | sh[34]eb-* | shbe-* \
-+ | sh-* | sh[1234]*-* | sh[23]e-* | sh[34]eb-* | shbe-* \
- | shle-* | sh[1234]le-* | sh3ele-* | sh64-* | sh64le-* \
- | sparc-* | sparc64-* | sparc86x-* | sparclet-* | sparclite-* \
- | sparcv8-* | sparcv9-* | sparcv9b-* | strongarm-* | sv1-* | sx?-* \
-@@ -884,9 +884,6 @@
- basic_machine=sh-hitachi
- os=-hms
- ;;
-- sh64)
-- basic_machine=sh64-unknown
-- ;;
- sparclite-wrs | simso-wrs)
- basic_machine=sparclite-wrs
- os=-vxworks
-@@ -1086,7 +1083,7 @@
- we32k)
- basic_machine=we32k-att
- ;;
-- sh3 | sh4 | sh[34]eb | sh[1234]le | sh[23]ele)
-+ sh2* | sh3 | sh4 | sh[34]eb | sh[1234]le | sh[23]ele)
- basic_machine=sh-unknown
- ;;
- sh64)
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index 9af6289d2..0d7c929c3 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -66,6 +66,7 @@ $(DL_DIR)/$(GCC_SOURCE):
$(GCC_DIR)/.unpacked: $(DL_DIR)/$(GCC_SOURCE)
mkdir -p $(TOOL_BUILD_DIR)
$(GCC_CAT) $(DL_DIR)/$(GCC_SOURCE) | tar -C $(TOOL_BUILD_DIR) $(TAR_OPTIONS) -
+ $(CONFIG_UPDATE) $(GCC_DIR)
touch $(GCC_DIR)/.unpacked
$(GCC_DIR)/.patched: $(GCC_DIR)/.unpacked