summaryrefslogtreecommitdiff
path: root/toolchain
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2005-12-21 15:27:33 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2005-12-21 15:27:33 +0000
commitde3f04efe5f20cc07f6cc8d57568d289303417df (patch)
tree32dce2d6f0a812eccb5ee6ef74ce411df8a1d306 /toolchain
parent3a1147b2b6aeedc9345a8c0a6a9d78d265be2735 (diff)
- no need to disable libmudflap for gcc-4.2
- use the HOSTCC for the intermediate bootstrap compilers
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index 6ac9b1a95..72a44224e 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -96,9 +96,6 @@ endif
endif
touch $(GCC_DIR)/.patched
-ifeq ("$(GCC_VERSION)","4.2.0")
-EXTRA_GCC_CONFIG_OPTIONS+= --disable-libmudflap
-endif
# The --without-headers option stopped working with gcc 3.0 and has never been
# fixed, so we need to actually have working C library header files prior to
# the step or libgcc will not build...
@@ -106,6 +103,7 @@ endif
$(GCC_BUILD_DIR1)/.configured: $(GCC_DIR)/.patched
mkdir -p $(GCC_BUILD_DIR1)
(cd $(GCC_BUILD_DIR1); PATH=$(TARGET_PATH) \
+ CC="$(HOSTCC)" \
$(GCC_DIR)/configure \
--prefix=$(STAGING_DIR) \
--build=$(GNU_HOST_NAME) \
@@ -162,6 +160,7 @@ $(GCC_BUILD_DIR2)/.configured: $(GCC_DIR)/.patched $(STAGING_DIR)/lib/libc.a
# Important! Required for limits.h to be fixed.
ln -snf ../include $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/sys-include
(cd $(GCC_BUILD_DIR2); PATH=$(TARGET_PATH) \
+ CC="$(HOSTCC)" \
$(GCC_DIR)/configure \
--prefix=$(STAGING_DIR) \
--build=$(GNU_HOST_NAME) \