summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--linux/linux.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 8b83e3066..71d961603 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -85,6 +85,16 @@ ifeq ($(BR2_LINUX_KERNEL_USE_DEFCONFIG),y)
else ifeq ($(BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG),y)
cp $(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE) $(@D)/.config
endif
+ifeq ($(BR2_ARM_EABI),y)
+ $(call KCONFIG_ENABLE_OPT,CONFIG_AEABI,$(@D)/.config)
+else
+ $(call KCONFIG_DISABLE_OPT,CONFIG_AEABI,$(@D)/.config)
+endif
+ifeq ($(BR2_INET_IPV6),y)
+ $(call KCONFIG_ENABLE_OPT,CONFIG_IPV6,$(@D)/.config)
+else
+ $(call KCONFIG_DISABLE_OPT,CONFIG_IPV6,$(@D)/.config)
+endif
$(TARGET_MAKE_ENV) $(MAKE) $(LINUX26_MAKE_FLAGS) -C $(@D) oldconfig
$(Q)touch $@