summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--package/Makefile.autotools.in7
-rw-r--r--package/Makefile.package.in6
2 files changed, 3 insertions, 10 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 495a07580..0f9b2c60f 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -203,12 +203,9 @@ endef
# This must be repeated from GENTARGETS_INNER, otherwise we get an empty
# _DEPENDENCIES if _AUTORECONF is YES. Also filter the result of _AUTORECONF
# away from the non-host rule
-ifndef $(2)_DEPENDENCIES
- ifdef $(3)_DEPENDENCIES
- $(2)_DEPENDENCIES = $(filter-out host-automake host-autoconf host-libtool,\
+$(2)_DEPENDENCIES ?= $(filter-out host-automake host-autoconf host-libtool,\
$(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES))))
- endif
-endif
+
ifeq ($$($(2)_AUTORECONF),YES)
$(2)_PRE_CONFIGURE_HOOKS += AUTORECONF_HOOK
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index a27804b81..e57bfed1b 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -542,11 +542,7 @@ $(2)_OVERRIDE_SRCDIR = $($(2)_SITE)
endif
endif
-ifndef $(2)_DEPENDENCIES
- ifdef $(3)_DEPENDENCIES
- $(2)_DEPENDENCIES = $(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES)))
- endif
-endif
+$(2)_DEPENDENCIES ?= $(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES)))
$(2)_INSTALL_STAGING ?= NO
$(2)_INSTALL_IMAGES ?= NO