summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 177701ef4..a0c18ba7c 100644
--- a/Makefile
+++ b/Makefile
@@ -634,11 +634,9 @@ help:
@echo 'See docs/README and docs/buildroot.html for further details'
@echo
-release: distclean
+release:
OUT=buildroot-$$(grep -A2 BR2_VERSION $(CONFIG_CONFIG_IN)|grep default|cut -f2 -d\"); \
- rm -rf ../$$OUT*; cp -al . ../$$OUT; cd ..; \
- tar cfz $$OUT.tar.gz --exclude .svn --exclude .git --exclude \*~ $$OUT; \
- rm -rf $$OUT
+ git archive --format=tar --prefix=$$OUT/ master|gzip -9 >$$OUT.tar.gz
.PHONY: $(noconfig_targets)