summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--package/multimedia/mplayer/mplayer.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/multimedia/mplayer/mplayer.mk b/package/multimedia/mplayer/mplayer.mk
index 719cc6754..b65d288a0 100644
--- a/package/multimedia/mplayer/mplayer.mk
+++ b/package/multimedia/mplayer/mplayer.mk
@@ -25,6 +25,11 @@ else
MPLAYER_LARGEFILE:=--disable-largefiles
endif
+ifeq ($(BR2_i386),y)
+# This seems to be required to compile some of the inline asm
+MPLAYER_CFLAGS:=-fomit-frame-pointer
+endif
+
$(DL_DIR)/$(MPLAYER_SOURCE):
$(call DOWNLOAD,$(MPLAYER_SITE),$(MPLAYER_SOURCE))
@@ -38,7 +43,7 @@ $(MPLAYER_DIR)/.configured: $(MPLAYER_DIR)/.unpacked
(cd $(MPLAYER_DIR); rm -rf config.cache; \
$(TARGET_CONFIGURE_OPTS) \
$(TARGET_CONFIGURE_ARGS) \
- CFLAGS="$(TARGET_CFLAGS)" \
+ CFLAGS="$(TARGET_CFLAGS) $(MPLAYER_CFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" \
./configure \
--prefix=/usr \