summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile9
-rw-r--r--package/Makefile.in1
-rw-r--r--toolchain/sstrip/sstrip.mk2
3 files changed, 2 insertions, 10 deletions
diff --git a/Makefile b/Makefile
index 22c3801d1..efc42ffc8 100644
--- a/Makefile
+++ b/Makefile
@@ -148,15 +148,6 @@ HOSTLD:=$(shell which $(HOSTLD) || type -p $(HOSTLD) || echo ld)
HOSTLN:=$(shell which $(HOSTLN) || type -p $(HOSTLN) || echo ln)
HOSTNM:=$(shell which $(HOSTNM) || type -p $(HOSTNM) || echo nm)
-ifndef CFLAGS_FOR_BUILD
-CFLAGS_FOR_BUILD:=-g -O2
-endif
-ifndef CXXFLAGS_FOR_BUILD
-CXXFLAGS_FOR_BUILD:=-g -O2
-endif
-ifndef FCFLAGS_FOR_BUILD
-FCFLAGS_FOR_BUILD:=-g -O2
-endif
export HOSTAR HOSTAS HOSTCC HOSTCXX HOSTFC HOSTLD
# bash prints the name of the directory on 'cd <dir>' if CDPATH is
diff --git a/package/Makefile.in b/package/Makefile.in
index fb09083de..971a7edc7 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -169,6 +169,7 @@ FLEX:=$(shell which flex || type -p flex)
BISON:=$(shell which bison || type -p bison)
SED:=$(shell which sed || type -p sed) -i -e
+HOST_CFLAGS ?= -O2
HOST_CFLAGS += -I$(HOST_DIR)/include -I$(HOST_DIR)/usr/include
HOST_CXXFLAGS += -I$(HOST_DIR)/include -I$(HOST_DIR)/usr/include
HOST_LDFLAGS += -L$(HOST_DIR)/lib -L$(HOST_DIR)/usr/lib -Wl,-rpath,$(HOST_DIR)/usr/lib
diff --git a/toolchain/sstrip/sstrip.mk b/toolchain/sstrip/sstrip.mk
index 48abbaa50..f387e2d9c 100644
--- a/toolchain/sstrip/sstrip.mk
+++ b/toolchain/sstrip/sstrip.mk
@@ -16,7 +16,7 @@ SSTRIP_HOST:=$(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-sstrip
$(SSTRIP_HOST): $(SSTRIP_SOURCE_FILE)
mkdir -p $(@D) $(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/bin
- $(HOSTCC) $(CFLAGS_FOR_BUILD) $(SSTRIP_SOURCE_FILE) -o $(SSTRIP_HOST)
+ $(HOSTCC) $(HOST_CFLAGS) $(SSTRIP_SOURCE_FILE) -o $(SSTRIP_HOST)
ln -snf ../../bin/$(REAL_GNU_TARGET_NAME)-sstrip \
$(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/bin/sstrip
ln -snf $(REAL_GNU_TARGET_NAME)-sstrip \