summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--toolchain/gdb/Config.in16
-rw-r--r--toolchain/gdb/Makefile.in6
-rw-r--r--toolchain/gdb/gdb.mk2
3 files changed, 15 insertions, 9 deletions
diff --git a/toolchain/gdb/Config.in b/toolchain/gdb/Config.in
index a17b736dc..3bf445ef3 100644
--- a/toolchain/gdb/Config.in
+++ b/toolchain/gdb/Config.in
@@ -1,7 +1,3 @@
-# Choose gcc version.
-# WARNING -- 2.95 currently only builds for i386, arm, mips*, and powerpc.
-# WARNING -- 2.95 does not currently build natively for the target.
-
comment "Gdb Options"
config BR2_PACKAGE_GDB
@@ -9,14 +5,20 @@ config BR2_PACKAGE_GDB
default n
select BR2_PACKAGE_NCURSES
help
- Enable the gdb debugger.
+ Build the full gdb debugger to run on the target.
config BR2_PACKAGE_GDB_SERVER
bool "Build gdb server for the Target"
default n
- select BR2_PACKAGE_NCURSES
help
- Enable the gdb debugger.
+ Build the gdbserver stub to run on the target.
+ A full gdb is needed to debug the progam.
+
+config BR2_PACKAGE_GDB_CLIENT
+ bool "Build gdb client for the Host"
+ default n
+ help
+ Build gdb to run on the host to debug programs running on the target.
choice
prompt "GDB debuger Version"
diff --git a/toolchain/gdb/Makefile.in b/toolchain/gdb/Makefile.in
index 51a2ddb3d..50828d86f 100644
--- a/toolchain/gdb/Makefile.in
+++ b/toolchain/gdb/Makefile.in
@@ -6,5 +6,9 @@ TARGETS+=gdb_target
endif
ifeq ($(strip $(BR2_PACKAGE_GDB_SERVER)),y)
-TARGETS+=gdbserver gdbclient
+TARGETS+=gdbserver
+endif
+
+ifeq ($(strip $(BR2_PACKAGE_GDB_CLIENT)),y)
+TARGETS+=gdbclient
endif
diff --git a/toolchain/gdb/gdb.mk b/toolchain/gdb/gdb.mk
index 862f84d7f..7c3c8deaa 100644
--- a/toolchain/gdb/gdb.mk
+++ b/toolchain/gdb/gdb.mk
@@ -135,7 +135,7 @@ $(GDB_SERVER_DIR)/gdbserver: $(GDB_SERVER_DIR)/.configured
$(TARGET_DIR)/usr/bin/gdbserver: $(GDB_SERVER_DIR)/gdbserver
install -c $(GDB_SERVER_DIR)/gdbserver $(TARGET_DIR)/usr/bin/gdbserver
-gdbserver: ncurses-headers $(TARGET_DIR)/usr/bin/gdbserver
+gdbserver: $(TARGET_DIR)/usr/bin/gdbserver
gdbserver-clean:
$(MAKE) -C $(GDB_SERVER_DIR) clean