summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--toolchain/gcc/Config.in10
-rw-r--r--toolchain/gcc/Config.in.212
-rw-r--r--toolchain/gcc/Makefile.in4
3 files changed, 3 insertions, 23 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 727b78997..b00df227a 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -140,16 +140,6 @@ config BR2_GCC_USE_SJLJ_EXCEPTIONS
proper stack unwinding during exception handling. Most people
can leave this set to n.
-config BR2_GCC_AVR32_CONFIGURATION
- bool "Enable default AVR32 GCC configuration"
- default y
- depends BR2_avr32
- help
- For the AVR32 platform there is some configuration which are not
- supported.
-
- Currently this will add "--disable-libmudflap" to configure.
-
config BR2_EXTRA_GCC_CONFIG_OPTIONS
string "Additional gcc options"
default ""
diff --git a/toolchain/gcc/Config.in.2 b/toolchain/gcc/Config.in.2
index 0b209ec7a..e556392c1 100644
--- a/toolchain/gcc/Config.in.2
+++ b/toolchain/gcc/Config.in.2
@@ -2,19 +2,9 @@ config BR2_PACKAGE_GCC_TARGET
bool "native toolchain in the target filesystem"
default n
help
- If you want the target system to be able to run
+ If you want the target system to be able to run
binutils/gcc and compile native code, say Y here.
-config BR2_GCC_TARGET_AVR32_CONFIGURATION
- bool "Enable default AVR32 GCC configuration"
- default y
- depends BR2_avr32 && BR2_PACKAGE_GCC_TARGET
- help
- For the AVR32 platform there is some configuration which are not
- supported.
-
- Currently this will add "--disable-libmudflap" to configure.
-
config BR2_EXTRA_TARGET_GCC_CONFIG_OPTIONS
string "Additional target gcc options"
default ""
diff --git a/toolchain/gcc/Makefile.in b/toolchain/gcc/Makefile.in
index ec14b25bd..b087eb22c 100644
--- a/toolchain/gcc/Makefile.in
+++ b/toolchain/gcc/Makefile.in
@@ -12,7 +12,7 @@ EXTRA_GCC_CONFIG_OPTIONS:=$(strip $(subst ",, $(BR2_EXTRA_GCC_CONFIG_OPTIONS)))
#"))
# AVR32 GCC configuration
-ifeq ($(strip $(BR2_GCC_AVR32_CONFIGURATION)),y)
+ifeq ($(strip $(BR2_avr32)),y)
EXTRA_GCC_CONFIG_OPTIONS+=--disable-libmudflap
endif
@@ -86,7 +86,7 @@ endif
endif # BR2_PREFER_IMA=y
# AVR32 target GCC configuration
-ifeq ($(strip $(BR2_GCC_TARGET_AVR32_CONFIGURATION)),y)
+ifeq ($(strip $(BR2_avr32)),y)
EXTRA_TARGET_GCC_CONFIG_OPTIONS+=--disable-libmudflap
endif