summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--target/Config.in.arch40
-rw-r--r--target/device/Arm/Config.in8
-rw-r--r--target/device/Arm/Makefile.in2
-rw-r--r--target/device/Arm/integrator926_defconfig4
-rw-r--r--target/device/Arm/integrator926_huge_defconfig4
-rw-r--r--target/device/Atmel/at91rm9200df/at91rm9200df_defconfig4
-rw-r--r--target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig4
-rw-r--r--target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig4
-rw-r--r--target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig4
-rw-r--r--target/linux-experimental/Makefile.in2
-rw-r--r--target/linux/Makefile.in2
-rw-r--r--toolchain/uClibc/uclibc.mk10
12 files changed, 43 insertions, 45 deletions
diff --git a/target/Config.in.arch b/target/Config.in.arch
index a6d611912..a4d03736d 100644
--- a/target/Config.in.arch
+++ b/target/Config.in.arch
@@ -111,13 +111,13 @@ config BR2_ARM_TYPE
choice
prompt "Target ABI"
depends BR2_arm || BR2_armeb
- default BR2_OABI
+ default BR2_ARM_OABI
help
Application Binary Interface to use
-config BR2_OABI
+config BR2_ARM_OABI
bool "OABI"
-config BR2_EABI
+config BR2_ARM_EABI
bool "EABI"
endchoice
@@ -150,15 +150,15 @@ endchoice
choice
prompt "Target ABI"
depends BR2_mips || BR2_mipsel
- default BR2_EABI
+ default BR2_MIPS_EABI
help
Application Binary Interface to use
-config BR2_OABI
+config BR2_MIPS_OABI
bool "OABI"
-config BR2_EABI
+config BR2_MIPS_EABI
bool "EABI"
-config BR2_ABI64
+config BR2_MIPS_ABI64
bool "N64"
endchoice
@@ -683,17 +683,17 @@ config BR2_GCC_TARGET_ABI
default aapcs if BR2_arm_dunno
default aapcs-linux if BR2_arm_dunno
default iwmmxt if BR2_iwmmxt
- default 32 if (BR2_mipsel || BR2_arm) && BR2_OABI
- default n32 if BR2_mipsel && BR2_EABI
- default o64 if BR2_mips && BR2_OABI
- default eabi if (BR2_mips || BR2_arm) && BR2_EABI
- default 64 if BR2_mips && BR2_ABI64
- default mmixware if BR2_mmix && BR2_ABI_native
- default gnu if BR2_mmix && !BR2_ABI_native
- default altivec if BR2_powerpc && BR2_ABI_altivec
- default no-altivec if BR2_powerpc && BR2_ABI_no-altivec
- default spe if BR2_powerpc && BR2_ABI_spe
- default no-spe if BR2_powerpc && BR2_ABI_no-spe
- default ibmlongdouble if BR2_powerpc && BR2_ABI_ibmlongdouble
- default ieeelongdouble if BR2_powerpc && BR2_ABI_ieeelongdouble
+ default 32 if BR2_mipsel && BR2_MIPS_OABI
+ default n32 if BR2_mipsel && BR2_MIPS_EABI
+ default o64 if BR2_mips && BR2_MIPS_OABI
+ default eabi if BR2_mips && BR2_MIPS_EABI
+ default 64 if BR2_mips && BR2_MIPS_ABI64
+ default mmixware if BR2_mmix && BR2_MMIX_ABI_native
+ default gnu if BR2_mmix && !BR2_MMIX_ABI_native
+ default altivec if BR2_powerpc && BR2_PPC_ABI_altivec
+ default no-altivec if BR2_powerpc && BR2_PPC_ABI_no-altivec
+ default spe if BR2_powerpc && BR2_PPC_ABI_spe
+ default no-spe if BR2_powerpc && BR2_PPC_ABI_no-spe
+ default ibmlongdouble if BR2_powerpc && BR2_PPC_ABI_ibmlongdouble
+ default ieeelongdouble if BR2_powerpc && BR2_PPC_ABI_ieeelongdouble
diff --git a/target/device/Arm/Config.in b/target/device/Arm/Config.in
index de50fea77..36934ee09 100644
--- a/target/device/Arm/Config.in
+++ b/target/device/Arm/Config.in
@@ -3,16 +3,15 @@ menuconfig BR2_TARGET_ARM
depends BR2_arm
default n
-if BR2_TARGET_ARM
comment "Arm based Device Support"
- depends BR2_arm
+ depends BR2_arm && BR2_TARGET_ARM
config BR2_TARGET_ARM_INTEGRATOR_926
bool "Integrator arm926"
- depends BR2_arm
+ depends BR2_arm && BR2_TARGET_ARM
default n
select BR2_PACKAGE_LINUX
- select BR2_EABI
+ select BR2_ARM_EABI
select BR2_KERNEL_HEADERS_2_6_22
select BR2_PTHREADS
select BR2_arm926t
@@ -20,4 +19,3 @@ config BR2_TARGET_ARM_INTEGRATOR_926
An ARM integrator 926 board for use with qemu.
This one has an MMU.
-endif
diff --git a/target/device/Arm/Makefile.in b/target/device/Arm/Makefile.in
index db1b81240..a55389e7f 100644
--- a/target/device/Arm/Makefile.in
+++ b/target/device/Arm/Makefile.in
@@ -7,7 +7,7 @@ UCLIBC_CONFIG_FILE:=target/device/Arm/uClibc.integrator926.config
endif
# pin some settings
-BR2_EABI:=y
+BR2_ARM_EABI:=y
BR2_GNU_TARGET_SUFFIX:="linux-uclibcgnueabi"
BR2_DEFAULT_KERNEL_HEADERS:="2.6.22.8"
endif
diff --git a/target/device/Arm/integrator926_defconfig b/target/device/Arm/integrator926_defconfig
index 2b4d9c676..1977375eb 100644
--- a/target/device/Arm/integrator926_defconfig
+++ b/target/device/Arm/integrator926_defconfig
@@ -39,8 +39,8 @@ BR2_arm926t=y
# BR2_xscale is not set
# BR2_iwmmxt is not set
BR2_ARM_TYPE="ARM926T"
-# BR2_OABI is not set
-BR2_EABI=y
+# BR2_ARM_OABI is not set
+BR2_ARM_EABI=y
# BR2_x86_i386 is not set
# BR2_x86_i486 is not set
# BR2_x86_i586 is not set
diff --git a/target/device/Arm/integrator926_huge_defconfig b/target/device/Arm/integrator926_huge_defconfig
index 72c0d0757..43e436ca3 100644
--- a/target/device/Arm/integrator926_huge_defconfig
+++ b/target/device/Arm/integrator926_huge_defconfig
@@ -39,8 +39,8 @@ BR2_arm926t=y
# BR2_xscale is not set
# BR2_iwmmxt is not set
BR2_ARM_TYPE="ARM926T"
-# BR2_OABI is not set
-BR2_EABI=y
+# BR2_ARM_OABI is not set
+BR2_ARM_EABI=y
BR2_ARCH="arm"
BR2_ENDIAN="LITTLE"
BR2_GCC_TARGET_TUNE="arm9tdmi"
diff --git a/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig b/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig
index ddbf9b624..38cdc8fcd 100644
--- a/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig
+++ b/target/device/Atmel/at91rm9200df/at91rm9200df_defconfig
@@ -153,8 +153,8 @@ BR2_GCC_VERSION_4_2_1=y
BR2_GCC_SUPPORTS_SYSROOT=y
# BR2_GCC_SUPPORTS_FINEGRAINEDMTUNE is not set
BR2_GCC_VERSION="4.2.1"
-BR2_OABI=y
-# BR2_EABI is not set
+BR2_ARM_OABI=y
+# BR2_ARM_EABI is not set
BR2_TOOLCHAIN_SYSROOT=y
# BR2_GCC_USE_SJLJ_EXCEPTIONS is not set
BR2_EXTRA_GCC_CONFIG_OPTIONS=""
diff --git a/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig b/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig
index e11611d25..69afb804b 100644
--- a/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig
+++ b/target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig
@@ -42,8 +42,8 @@ BR2_generic_arm=y
# BR2_xscale is not set
# BR2_iwmmxt is not set
BR2_ARM_TYPE="GENERIC_ARM"
-BR2_OABI=y
-# BR2_EABI is not set
+BR2_ARM_OABI=y
+# BR2_ARM_EABI is not set
BR2_ARCH="arm"
BR2_ENDIAN="LITTLE"
diff --git a/target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig b/target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig
index 54af41f40..36dd77a5b 100644
--- a/target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig
+++ b/target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig
@@ -44,8 +44,8 @@ BR2_generic_arm=y
# BR2_xscale is not set
# BR2_iwmmxt is not set
BR2_ARM_TYPE="GENERIC_ARM"
-BR2_OABI=y
-# BR2_EABI is not set
+BR2_ARM_OABI=y
+# BR2_ARM_EABI is not set
BR2_ARCH="arm"
BR2_ENDIAN="LITTLE"
diff --git a/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig b/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig
index 265eb0b91..5558c2cf3 100644
--- a/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig
+++ b/target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig
@@ -44,8 +44,8 @@ BR2_generic_arm=y
# BR2_xscale is not set
# BR2_iwmmxt is not set
BR2_ARM_TYPE="GENERIC_ARM"
-BR2_OABI=y
-# BR2_EABI is not set
+BR2_ARM_OABI=y
+# BR2_ARM_EABI is not set
BR2_ARCH="arm"
BR2_ENDIAN="LITTLE"
diff --git a/target/linux-experimental/Makefile.in b/target/linux-experimental/Makefile.in
index bfad7c5b4..ab9a6135d 100644
--- a/target/linux-experimental/Makefile.in
+++ b/target/linux-experimental/Makefile.in
@@ -184,7 +184,7 @@ ifeq ($(strip $(BR2_LINUX_CUSTOMIZE)),y)
make -C $(LINUX26_DIR) xconfig
endif
$(SED) '/CONFIG_AEABI/d' $(LINUX26_DIR)/.config
-ifeq ($(BR2_EABI),y)
+ifeq ($(BR2_ARM_EABI),y)
echo "CONFIG_AEABI=y" >> $(LINUX26_DIR)/.config
$(SED) '/CONFIG_OABI_COMPAT/d' $(LINUX26_DIR)/.config
echo "# CONFIG_OABI_COMPAT is not set" >> $(LINUX26_DIR)/.config
diff --git a/target/linux/Makefile.in b/target/linux/Makefile.in
index bf5b9492d..14d4e085e 100644
--- a/target/linux/Makefile.in
+++ b/target/linux/Makefile.in
@@ -148,7 +148,7 @@ endif
$(LINUX26_DIR)/.configured: $(LINUX26_DIR)/.patched $(LINUX26_KCONFIG)
cp -dpf $(LINUX26_KCONFIG) $(LINUX26_DIR)/.config
$(SED) '/CONFIG_AEABI=y/d' $(LINUX26_DIR)/.config
-ifeq ($(BR2_EABI),y)
+ifeq ($(BR2_ARM_EABI),y)
echo "CONFIG_AEABI=y" >> $(LINUX26_DIR)/.config
$(SED) '/CONFIG_OABI_COMPAT/d' $(LINUX26_DIR)/.config
echo "# CONFIG_OABI_COMPAT is not set" >> $(LINUX26_DIR)/.config
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index 2172d1103..1bef774f0 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -139,11 +139,11 @@ ifeq ($(UCLIBC_TARGET_ARCH),arm)
$(UCLIBC_DIR)/.oldconfig
$(SED) 's/^.*$(UCLIBC_ARM_TYPE).*/$(UCLIBC_ARM_TYPE)=y/g' $(UCLIBC_DIR)/.oldconfig
$(SED) '/CONFIG_ARM_.ABI/d' $(UCLIBC_DIR)/.oldconfig
-ifeq ($(BR2_EABI),y)
+ifeq ($(BR2_ARM_EABI),y)
/bin/echo "# CONFIG_ARM_OABI is not set" >> $(UCLIBC_DIR)/.oldconfig
/bin/echo "CONFIG_ARM_EABI=y" >> $(UCLIBC_DIR)/.oldconfig
endif
-ifeq ($(BR2_OABI),y)
+ifeq ($(BR2_ARM_OABI),y)
/bin/echo "CONFIG_ARM_OABI=y" >> $(UCLIBC_DIR)/.oldconfig
/bin/echo "# CONFIG_ARM_EABI is not set" >> $(UCLIBC_DIR)/.oldconfig
endif
@@ -154,13 +154,13 @@ ifeq ($(UCLIBC_TARGET_ARCH),mips)
/bin/echo "# CONFIG_MIPS_N32_ABI is not set"; \
/bin/echo "# CONFIG_MIPS_N64_ABI is not set"; \
) >> $(UCLIBC_DIR)/.oldconfig
-ifeq ($(BR2_OABI),y)
+ifeq ($(BR2_MIPS_OABI),y)
$(SED) 's/.*\(CONFIG_MIPS_O32_ABI\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
endif
-ifeq ($(BR2_EABI),y)
+ifeq ($(BR2_MIPS_EABI),y)
$(SED) 's/.*\(CONFIG_MIPS_N32_ABI\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
endif
-ifeq ($(BR2_ABI64),y)
+ifeq ($(BR2_MIPS_ABI64),y)
$(SED) 's/.*\(CONFIG_MIPS_N64_ABI\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
endif
endif