summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES2
-rw-r--r--package/qt/qt.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/CHANGES b/CHANGES
index 8c6d645a2..7a3fe09f4 100644
--- a/CHANGES
+++ b/CHANGES
@@ -2,7 +2,7 @@
Fixes all over the tree.
- Updated/fixed packages: aumix, avahi, busybox, mtd-utils, ntp
+ Updated/fixed packages: aumix, avahi, busybox, mtd-utils, ntp, qt
Issues resolved (http://bugs.uclibc.org):
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index 4f42e59e8..aaf965e3c 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -372,7 +372,7 @@ BR2_PACKAGE_QT_EMB_PLATFORM:=$(call qstrip,$(BR2_PACKAGE_QT_EMB_PLATFORM))
# x86x86fix
# Workaround Qt Embedded bug when crosscompiling for x86 under x86 with linux
# host. It's unclear if this would happen on other hosts.
-ifneq ($(findstring unknown-linux,$(GNU_HOST_NAME)),)
+ifneq ($(findstring linux,$(GNU_HOST_NAME)),)
ifneq ($(findstring x86,$(BR2_PACKAGE_QT_EMB_PLATFORM)),)
QT_CONFIGURE+= -platform linux-g++
endif