summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--package/Makefile.autotools.in10
-rw-r--r--package/Makefile.package.in7
2 files changed, 16 insertions, 1 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index c84afa0b1..495a07580 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -200,6 +200,16 @@ define AUTORECONF_HOOK
fi
endef
+# This must be repeated from GENTARGETS_INNER, otherwise we get an empty
+# _DEPENDENCIES if _AUTORECONF is YES. Also filter the result of _AUTORECONF
+# away from the non-host rule
+ifndef $(2)_DEPENDENCIES
+ ifdef $(3)_DEPENDENCIES
+ $(2)_DEPENDENCIES = $(filter-out host-automake host-autoconf host-libtool,\
+ $(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES))))
+ endif
+endif
+
ifeq ($$($(2)_AUTORECONF),YES)
$(2)_PRE_CONFIGURE_HOOKS += AUTORECONF_HOOK
$(2)_DEPENDENCIES += host-automake host-autoconf host-libtool
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index e85eb1549..a27804b81 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -542,7 +542,12 @@ $(2)_OVERRIDE_SRCDIR = $($(2)_SITE)
endif
endif
-$(2)_DEPENDENCIES ?=
+ifndef $(2)_DEPENDENCIES
+ ifdef $(3)_DEPENDENCIES
+ $(2)_DEPENDENCIES = $(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES)))
+ endif
+endif
+
$(2)_INSTALL_STAGING ?= NO
$(2)_INSTALL_IMAGES ?= NO
$(2)_INSTALL_TARGET ?= YES