summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--package/sdl_sound/Config.in1
-rw-r--r--package/sdl_sound/sdl_sound.mk4
2 files changed, 5 insertions, 0 deletions
diff --git a/package/sdl_sound/Config.in b/package/sdl_sound/Config.in
index 08ad7542c..542c996b2 100644
--- a/package/sdl_sound/Config.in
+++ b/package/sdl_sound/Config.in
@@ -1,6 +1,7 @@
config BR2_PACKAGE_SDL_SOUND
bool "SDL_sound"
depends on BR2_PACKAGE_SDL
+ select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
help
SDL_sound is a library that handles the decoding of several
popular sound file formats, such as .WAV and .MP3.
diff --git a/package/sdl_sound/sdl_sound.mk b/package/sdl_sound/sdl_sound.mk
index 610e9681a..5058551b0 100644
--- a/package/sdl_sound/sdl_sound.mk
+++ b/package/sdl_sound/sdl_sound.mk
@@ -11,6 +11,10 @@ SDL_SOUND_INSTALL_STAGING:=YES
SDL_SOUND_INSTALL_TARGET:=YES
SDL_SOUND_DEPENDENCIES = sdl
+ifneq ($(BR2_ENABLE_LOCALE),y)
+SDL_SOUND_DEPENDENCIES += libiconv
+endif
+
SDL_SOUND_CONF_OPT:=--with-sdl-prefix=$(STAGING_DIR)/usr \
--with-sdl-exec-prefix=$(STAGING_DIR)/usr \
--disable-sdltest \