summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--linux/Config.in8
-rw-r--r--linux/linux.mk3
2 files changed, 11 insertions, 0 deletions
diff --git a/linux/Config.in b/linux/Config.in
index 1f1a69c44..bdfa5b7ef 100644
--- a/linux/Config.in
+++ b/linux/Config.in
@@ -153,6 +153,14 @@ config BR2_LINUX_KERNEL_IMAGE_TARGET_NAME
Specify the kernel make target to build the kernel that you
need.
+config BR2_LINUX_KERNEL_INSTALL_TARGET
+ bool "Install kernel image to /boot in target"
+ depends on !BR2_TARGET_ROOTFS_INITRAMFS
+ help
+ Select this option to have the kernel image installed to
+ /boot in the target root filesystem, as is typically done on
+ x86/x86_64 systems.
+
endif # BR2_LINUX_KERNEL
endmenu
diff --git a/linux/linux.mk b/linux/linux.mk
index 43ca87b9f..a5b9b8e2e 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -157,6 +157,9 @@ $(LINUX26_DIR)/.stamp_compiled: $(LINUX26_DIR)/.stamp_configured $(LINUX26_DIR)/
# Installation
$(LINUX26_DIR)/.stamp_installed: $(LINUX26_DIR)/.stamp_compiled
@$(call MESSAGE,"Installing kernel")
+ifeq ($(BR2_LINUX_KERNEL_INSTALL_TARGET),y)
+ install -m 0644 -D $(LINUX26_IMAGE_PATH) $(TARGET_DIR)/boot/$(LINUX26_IMAGE_NAME)
+endif
cp $(LINUX26_IMAGE_PATH) $(BINARIES_DIR)
# Install modules and remove symbolic links pointing to build
# directories, not relevant on the target