summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--package/busybox/busybox.mk5
-rwxr-xr-xpackage/busybox/udhcpc.script (renamed from fs/skeleton/usr/share/udhcpc/default.script)0
2 files changed, 4 insertions, 1 deletions
diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index b7f474091..1010df38d 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -141,7 +141,10 @@ endif
define BUSYBOX_INSTALL_TARGET_CMDS
$(BUSYBOX_INSTALL_BINARY)
- -chmod a+rx $(TARGET_DIR)/usr/share/udhcpc/default.script
+ if [ ! -f $(TARGET_DIR)/usr/share/udhcpc/default.script ]; then \
+ $(INSTALL) -m 0755 -D package/busybox/udhcpc.script \
+ $(TARGET_DIR)/usr/share/udhcpc/default.script; \
+ fi
endef
define BUSYBOX_UNINSTALL_TARGET_CMDS
diff --git a/fs/skeleton/usr/share/udhcpc/default.script b/package/busybox/udhcpc.script
index a52a7f812..a52a7f812 100755
--- a/fs/skeleton/usr/share/udhcpc/default.script
+++ b/package/busybox/udhcpc.script