summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES2
-rw-r--r--package/tcpdump/tcpdump.mk7
2 files changed, 8 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index 87056ed27..f696164f4 100644
--- a/CHANGES
+++ b/CHANGES
@@ -2,7 +2,7 @@
Fixes all over the tree.
- Updated/fixed packages: qt, xserver-xorg
+ Updated/fixed packages: qt, tcpdump, xserver-xorg
Issues resolved (http://bugs.uclibc.org):
diff --git a/package/tcpdump/tcpdump.mk b/package/tcpdump/tcpdump.mk
index e295e6902..81228169b 100644
--- a/package/tcpdump/tcpdump.mk
+++ b/package/tcpdump/tcpdump.mk
@@ -14,4 +14,11 @@ TCPDUMP_CONF_OPT:=--without-crypto \
$(if $(BR2_PACKAGE_TCPDUMP_SMB),--enable-smb,--disable-smb)
TCPDUMP_DEPENDENCIES:=zlib libpcap
+# make install installs an unneeded extra copy of the tcpdump binary
+define TCPDUMP_REMOVE_DUPLICATED_BINARY
+ rm -f $(TARGET_DIR)/usr/sbin/tcpdump.$(TCPDUMP_VERSION)
+endef
+
+TCPDUMP_POST_INSTALL_TARGET_HOOKS += TCPDUMP_REMOVE_DUPLICATED_BINARY
+
$(eval $(call AUTOTARGETS,package,tcpdump))