summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile1
-rw-r--r--package/config/Makefile7
2 files changed, 4 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index cdd16a2cb..df276c11b 100644
--- a/Makefile
+++ b/Makefile
@@ -578,7 +578,6 @@ ifeq ($(O),output)
rm -rf $(O)
endif
rm -rf $(CONFIG_DIR)/.config $(CONFIG_DIR)/.config.old $(CONFIG_DIR)/.config.cmd $(CONFIG_DIR)/.auto.deps
- -$(MAKE) -C $(CONFIG) distclean
flush:
rm -f $(BUILD_DIR)/tgt-config.cache
diff --git a/package/config/Makefile b/package/config/Makefile
index f0a030f80..2b266b872 100644
--- a/package/config/Makefile
+++ b/package/config/Makefile
@@ -2,6 +2,7 @@ src := .
top_srcdir=../../
top_builddir=../../
srctree := .
+obj ?= .
include Makefile.kconfig
#HOSTCFLAGS+=-Dinline="" -include foo.h
@@ -42,11 +43,11 @@ $(obj)/%:: $(src)/%_shipped
$(Q)cat $< > $@
clean:
- $(Q)rm -f $(clean-files)
+ $(Q)rm -f $(addprefix $(obj)/,$(clean-files))
distclean: clean
- $(Q)rm -f $(lxdialog) $(conf-objs) $(mconf-objs) $(kxgettext-objs) \
+ $(Q)rm -f $(addprefix $(obj)/,$(lxdialog) $(conf-objs) $(mconf-objs) $(kxgettext-objs) \
$(hostprogs-y) $(qconf-cxxobjs) $(qconf-objs) $(gconf-objs) \
- mconf .depend
+ mconf .depend)
FORCE:
.PHONY: FORCE clean distclean