summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--fs/jffs2/Config.in5
-rw-r--r--fs/jffs2/jffs2.mk10
2 files changed, 1 insertions, 14 deletions
diff --git a/fs/jffs2/Config.in b/fs/jffs2/Config.in
index edb1f4d94..5748fbb63 100644
--- a/fs/jffs2/Config.in
+++ b/fs/jffs2/Config.in
@@ -80,11 +80,6 @@ config BR2_TARGET_ROOTFS_JFFS2_NOCLEANMARKER
Do not use cleanmarkers if using NAND flash or Dataflash where
the pagesize is not a power of 2
-config BR2_JFFS2_TARGET_SREC
- bool "RootFS in SREC file format"
- help
- The binary data will be encoded in Motorola's S-record format
-
config BR2_TARGET_ROOTFS_JFFS2_PAD
bool "Pad output"
diff --git a/fs/jffs2/jffs2.mk b/fs/jffs2/jffs2.mk
index fd5da0c1b..2a69849cd 100644
--- a/fs/jffs2/jffs2.mk
+++ b/fs/jffs2/jffs2.mk
@@ -46,12 +46,4 @@ define ROOTFS_JFFS2_CMD
endef
endif
-define JFFS2_GEN_SREC
- $(TARGET_CROSS)objcopy -I binary -O srec --adjust-vma 0xa1000000 $$@ $$@.srec
-endef
-
-ifeq ($(BR2_JFFS2_TARGET_SREC),y)
-ROOTFS_JFFS2_POST_GEN_HOOKS += JFFS2_GEN_SREC
-endif
-
-$(eval $(call ROOTFS_TARGET,jffs2)) \ No newline at end of file
+$(eval $(call ROOTFS_TARGET,jffs2))