summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--package/neon/neon.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/neon/neon.mk b/package/neon/neon.mk
index 2e1da07b5..7f7f391de 100644
--- a/package/neon/neon.mk
+++ b/package/neon/neon.mk
@@ -32,6 +32,13 @@ ifeq ($(BR2_PACKAGE_NEON_NOXML),y)
NEON_CONF_OPT+=--disable-webdav
endif
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+NEON_CONF_OPT+=--with-ssl
+NEON_DEPENDENCIES+=openssl
+else
+NEON_CONF_OPT+=--without-ssl
+endif
+
$(eval $(call AUTOTARGETS,package,neon))
ifeq ($(BR2_ENABLE_DEBUG),)