summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--boot/u-boot/Config.in8
-rw-r--r--boot/u-boot/u-boot.mk2
2 files changed, 1 insertions, 9 deletions
diff --git a/boot/u-boot/Config.in b/boot/u-boot/Config.in
index 78c03ffb8..3ba1ef3a9 100644
--- a/boot/u-boot/Config.in
+++ b/boot/u-boot/Config.in
@@ -28,12 +28,6 @@ config BR2_TARGET_UBOOT_2010_06
config BR2_TARGET_UBOOT_2010_03
bool "2010.03"
-config BR2_TARGET_UBOOT_2009_11
- bool "2009.11"
-
-config BR2_TARGET_UBOOT_2009_08
- bool "2009.08"
-
config BR2_TARGET_UBOOT_CUSTOM_TARBALL
bool "Custom tarball"
@@ -52,8 +46,6 @@ config BR2_TARGET_UBOOT_VERSION
default "2010.09" if BR2_TARGET_UBOOT_2010_09
default "2010.06" if BR2_TARGET_UBOOT_2010_06
default "2010.03" if BR2_TARGET_UBOOT_2010_03
- default "2009.11" if BR2_TARGET_UBOOT_2009_11
- default "2009.08" if BR2_TARGET_UBOOT_2009_08
default "custom" if BR2_TARGET_UBOOT_CUSTOM_TARBALL
config BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR
diff --git a/boot/u-boot/u-boot.mk b/boot/u-boot/u-boot.mk
index bd26f52f8..a86819b5d 100644
--- a/boot/u-boot/u-boot.mk
+++ b/boot/u-boot/u-boot.mk
@@ -43,7 +43,7 @@ U_BOOT_TARGETS:=$(BINARIES_DIR)/$(U_BOOT_BIN) $(MKIMAGE)
U_BOOT_ARCH=$(KERNEL_ARCH)
# u-boot in the past used arch=ppc for powerpc
-ifneq ($(findstring x200,x$(U_BOOT_VERSION))$(findstring x2010.03,x$(U_BOOT_VERSION)),)
+ifneq ($(findstring x2010.03,x$(U_BOOT_VERSION)),)
U_BOOT_ARCH=$(KERNEL_ARCH:powerpc=ppc)
endif