summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES1
-rw-r--r--Makefile2
2 files changed, 2 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index 06a7e53cd..a6016cc61 100644
--- a/CHANGES
+++ b/CHANGES
@@ -31,6 +31,7 @@
#3595: patch to add libroxml
#3565: libnss: Add new package
#3907: 2011.05 - Qt 4.7.3 not building on ARM
+ #3985: "help" target's defconfig list needs sort
2011.05, Released May 27th, 2011:
diff --git a/Makefile b/Makefile
index ffe634391..02a165999 100644
--- a/Makefile
+++ b/Makefile
@@ -668,7 +668,7 @@ endif
@echo ' make V=0|1 - 0 => quiet build (default), 1 => verbose build'
@echo ' make O=dir - Locate all output files in "dir", including .config'
@echo
- @$(foreach b, $(notdir $(wildcard $(TOPDIR)/configs/*_defconfig)), \
+ @$(foreach b, $(sort $(notdir $(wildcard $(TOPDIR)/configs/*_defconfig))), \
printf " %-35s - Build for %s\\n" $(b) $(b:_defconfig=);)
@echo
@echo 'See docs/README and docs/buildroot.html for further details'