summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--boot/u-boot/u-boot.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/boot/u-boot/u-boot.mk b/boot/u-boot/u-boot.mk
index 971920751..93825e125 100644
--- a/boot/u-boot/u-boot.mk
+++ b/boot/u-boot/u-boot.mk
@@ -144,7 +144,7 @@ $(BINARIES_DIR)/$(U_BOOT_BIN): $(U_BOOT_DIR)/$(U_BOOT_BIN)
# uImage.
$(MKIMAGE): $(U_BOOT_DIR)/.patched
mkdir -p $(@D)
- $(MAKE) -C $(U_BOOT_DIR) tools
+ $(MAKE) -C $(U_BOOT_DIR) CROSS_COMPILE="$(TARGET_CROSS)" ARCH=$(U_BOOT_ARCH) tools
cp -dpf $(U_BOOT_DIR)/tools/mkimage $(@D)
# Build manually mkimage for the target