summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile1
-rw-r--r--package/Makefile.autotools.in1
2 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 5231bb6fa..2219f2b08 100644
--- a/Makefile
+++ b/Makefile
@@ -318,6 +318,7 @@ endif
$(PROJECT_BUILD_DIR)/.root:
mkdir -p $(TARGET_DIR)
+ mkdir -p $(PROJECT_BUILD_DIR)/autotools-stamps
if ! [ -d "$(TARGET_DIR)/bin" ]; then \
if [ -d "$(TARGET_SKELETON)" ]; then \
cp -fa $(TARGET_SKELETON)/* $(TARGET_DIR)/; \
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 1a38d4ffb..6d62c047a 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -258,7 +258,6 @@ $(PROJECT_BUILD_DIR)/autotools-stamps/%_target_installed:
$(if $(BR2_HAVE_DOCUMENTATION),,for d in doc share/doc; do \
rm -rf $(TARGET_DIR)/$$d $(TARGET_DIR)/usr/$$d; \
done)
- $(Q)mkdir -p $(@D)
touch $@
$(BUILD_DIR)/%/.stamp_cleaned: