summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--package/libxslt/libxslt.mk14
1 files changed, 7 insertions, 7 deletions
diff --git a/package/libxslt/libxslt.mk b/package/libxslt/libxslt.mk
index fec85f023..2a1730e94 100644
--- a/package/libxslt/libxslt.mk
+++ b/package/libxslt/libxslt.mk
@@ -8,18 +8,18 @@ LIBXSLT_VERSION = 1.1.26
LIBXSLT_SITE = ftp://xmlsoft.org/libxslt
LIBXSLT_INSTALL_STAGING = YES
+LIBXSLT_CONF_OPT = --with-gnu-ld --without-debug \
+ --without-python --with-libxml-prefix=$(STAGING_DIR)/usr/
+
+LIBXSLT_DEPENDENCIES = libxml2
+
# If we have enabled libgcrypt then use it, else disable crypto support.
ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
-LIBXSLT_DEPENDENCIES_EXTRA=libgcrypt
+LIBXSLT_DEPENDENCIES += libgcrypt
else
-LIBXSLT_XTRA_CONF_OPT = --without-crypto
+LIBXSLT_CONF_OPT = --without-crypto
endif
-LIBXSLT_CONF_OPT = --with-gnu-ld $(LIBXSLT_XTRA_CONF_OPT) --without-debug \
- --without-python --with-libxml-prefix=$(STAGING_DIR)/usr/
-
-LIBXSLT_DEPENDENCIES = libxml2 $(LIBXSLT_DEPENDENCIES_EXTRA)
-
HOST_LIBXSLT_CONF_OPT = --without-debug --without-python --without-crypto
HOST_LIBXSLT_DEPENDENCIES = host-libxml2