summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--target/Config.in.arch21
-rw-r--r--toolchain/uClibc/Config.in24
-rw-r--r--toolchain/uClibc/uclibc.mk2
3 files changed, 25 insertions, 22 deletions
diff --git a/target/Config.in.arch b/target/Config.in.arch
index 860bf439a..548691d43 100644
--- a/target/Config.in.arch
+++ b/target/Config.in.arch
@@ -202,27 +202,6 @@ config BR2_iwmmxt
bool "iwmmxt"
endchoice
-config BR2_ARM_TYPE
- string
- default GENERIC_ARM if BR2_generic_arm
- default ARM610 if BR2_arm610
- default ARM710 if BR2_arm710
- default ARM7TDMI if BR2_arm7tdmi
- default ARM720T if BR2_arm720t
- default ARM920T if BR2_arm920t
- default ARM922T if BR2_arm922t
- default ARM926T if BR2_arm926t
- default ARM10T if BR2_arm10t
- default ARM1136JF_S if BR2_arm1136jf_s
- default ARM1176JZ_S if BR2_arm1176jz_s
- default ARM1176JZF_S if BR2_arm1176jzf_s
- default ARM_SA110 if BR2_sa110
- default ARM_SA1100 if BR2_sa1100
- default ARM_XSCALE if BR2_xscale
- default ARM_IWMMXT if BR2_iwmmxt
- default ARM_CORTEXA8 if BR2_cortex_a8
- default ARM_CORTEXA9 if BR2_cortex_a9
-
choice
prompt "Target ABI"
depends on BR2_arm || BR2_armeb
diff --git a/toolchain/uClibc/Config.in b/toolchain/uClibc/Config.in
index d8b8a2a0c..fbe617afd 100644
--- a/toolchain/uClibc/Config.in
+++ b/toolchain/uClibc/Config.in
@@ -74,3 +74,27 @@ config BR2_UCLIBC_INSTALL_TEST_SUITE
This is not needed at all for normal builds, so you can safely say no
if you do not plan to dig into your C library.
+
+# This is only useful for uClibc <= 0.9.32. It can be removed once
+# Buildroot will support only uClibc >= 0.9.33 on ARM.
+config BR2_UCLIBC_ARM_TYPE
+ string
+ depends on BR2_arm || BR2_armeb
+ default GENERIC_ARM if BR2_generic_arm
+ default ARM610 if BR2_arm610
+ default ARM710 if BR2_arm710
+ default ARM7TDMI if BR2_arm7tdmi
+ default ARM720T if BR2_arm720t
+ default ARM920T if BR2_arm920t
+ default ARM922T if BR2_arm922t
+ default ARM926T if BR2_arm926t
+ default ARM10T if BR2_arm10t
+ default ARM1136JF_S if BR2_arm1136jf_s
+ default ARM1176JZ_S if BR2_arm1176jz_s
+ default ARM1176JZF_S if BR2_arm1176jzf_s
+ default ARM_SA110 if BR2_sa110
+ default ARM_SA1100 if BR2_sa1100
+ default ARM_XSCALE if BR2_xscale
+ default ARM_IWMMXT if BR2_iwmmxt
+ default ARM_CORTEXA8 if BR2_cortex_a8
+ default ARM_CORTEXA9 if BR2_cortex_a9
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index 534550a07..7b312d324 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -49,7 +49,7 @@ else
UCLIBC_NOT_TARGET_ENDIAN:=LITTLE
endif
-UCLIBC_ARM_TYPE:=CONFIG_$(call qstrip,$(BR2_ARM_TYPE))
+UCLIBC_ARM_TYPE:=CONFIG_$(call qstrip,$(BR2_UCLIBC_ARM_TYPE))
UCLIBC_SPARC_TYPE:=CONFIG_SPARC_$(call qstrip,$(BR2_SPARC_TYPE))
ifeq ($(GENERATE_LOCALE),)