summaryrefslogtreecommitdiff
path: root/boot/barebox/barebox.mk
diff options
context:
space:
mode:
Diffstat (limited to 'boot/barebox/barebox.mk')
-rw-r--r--boot/barebox/barebox.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/boot/barebox/barebox.mk b/boot/barebox/barebox.mk
index 7c2cbc123..85224cae0 100644
--- a/boot/barebox/barebox.mk
+++ b/boot/barebox/barebox.mk
@@ -53,9 +53,11 @@ barebox: $(BAREBOX_DIR)/.installed
ifeq ($(BR2_TARGET_BAREBOX),y)
TARGETS+=barebox
-# we NEED a board defconfig file
+# we NEED a board defconfig file unless we're at make source
+ifeq ($(filter source,$(MAKECMDGOALS)),)
ifeq ($(BAREBOX_BOARD_DEFCONFIG),)
$(error No Barebox defconfig file. Check your BR2_TARGET_BAREBOX_BOARD_DEFCONFIG setting)
endif
+endif
endif